Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

OpenVZ - update error
New on LowEndTalk? Please Register and read our Community Rules.

OpenVZ - update error


When I run the command

yum update

I have this error message

Loaded plugins: fastestmirror, security

Setting up Update Process

Loading mirror speeds from cached hostfile

  • base:

  • extras:

  • openvz-kernel-rhel6:

  • openvz-utils:

  • updates:

Resolving Dependencies

--> Running transaction check

---> Package vzkernel.x86_64 0:2.6.32-042stab104.1 will be installed

--> Processing Dependency: kernel-firmware >= 2.6.32-504.8.1.el6 for package: vzkernel-2.6.32-042stab104.1.x86_64

--> Finished Dependency Resolution

Error: Package: vzkernel-2.6.32-042stab104.1.x86_64 (openvz-kernel-rhel6)

       Requires: kernel-firmware >= 2.6.32-504.8.1.el6

       Installed: kernel-firmware-2.6.32-504.3.3.el6.noarch (@updates)

           kernel-firmware = 2.6.32-504.3.3.el6

You could try using --skip-broken to work around the problem

You could try running: rpm -Va --nofiles --nodigest

Can you help me

thank you


  • SpeedBusSpeedBus Member, Host Rep
    yum update -x kernel*

    should do it :)

  • @SpeedBus said:

    > yum update -x kernel*

    should do it :)

    it does not work, I still have the same error message

  • TACServersTACServers Member
    edited March 2015

    Try yum upgrade --skip-broken

  • FrankZFrankZ Veteran

    Make sure /etc/yum.conf does not contain "exclude=kernel*".
    "exclude=kernel" is ok.

  • vdnetvdnet Member
    edited March 2015

    rpm -Uvh --force

    Might need a --nodeps. Then the vzkernel update should work.

    FrankZ might be right with your excludes. You can use vzkernel-firmware instead of kernel-firmware as well, but it isn't necessary with CentOS/RHEL.

Sign In or Register to comment.