Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


New on LowEndTalk? Please Register and read our Community Rules.

All new Registrations are manually reviewed and approved, so a short delay after registration may occur before your account becomes active.

Got a problem with nginx

xprotoceptxprotocept Member
edited October 2011 in General

Ey

I got a problem with nginx
I get this error when i try to start it, i installed nginx with the LEB Script

Error Code:
Restarting nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
[emerg]: socket() [::]:80 failed (97: Address family not supported by protocol)
configuration file /etc/nginx/nginx.conf test failed

Can someone help me with this?

Comments

  • Hmm, no IPv6 support on your server? That line is specific for listening to IPv6 requests.

  • try compiling your nginx with ipv6 support

  • Yeah i found it, it's fixed now
    But now i got another problem, 502 Bad Gateway
    Seems like php-cgi isn't running on port 9000
    where can i find out on which port it is running?

  • I use sockets

    fastcgi.server = ( ".php" => ((
    "bin-path" => "/path/to/php-cgi",
    "socket" => "/tmp/php.socket"
    )))

    To find out what port it is running on though

    netstat -l should show it

  • The original LEB script uses Unix sockets, my script uses TCP so you can run PHP on a separate machine if needed. At any rate, look for $ /etc/init.d/php... to find the "php-cgi" or "php5-fpm" or "php-fastcgi" script and run restart on it.

  • Still doesn't work
    Installed lighttpd now, don't know much about lighttpd but will google some stuff when i need to add more websites

  • Look at php-fpm.conf and check what the port is set to, or if it's using unix sockets.

  • @kairus check the date of the last post...
    And i already fixed it

  • @xprotocept said: @kairus check the date of the last post...

    And i already fixed it

    Weird, dunno how i got to this thread then.

  • got this problem just recently. just delete
    /etc/nginx/sites-enabled/default
    /etc/nginx/sites-available/default
    as they enable ipv6 to On.

  • InfinityInfinity Member, Host Rep

    That thread is nearly 5 months old ;)
    Also deleting those files deletes the default server defenition assuming you used LEA's script.

  • @Infinity yes, found it via google. just want to update it in case anyone encountered the problem

  • yomeroyomero Member
    edited April 2012

    Deleting isn't the way to go...
    Open the file, and read what is happening

    /necromancer assistant

  • netomxnetomx Moderator, Veteran

    Just delete in the default file the ipv6 line, and that's all. I did it yesterday, too haha

  • jcalebjcaleb Member

    @yomero yes agree. i was thinking the culprit was in that file. that's why my first impression is to delete

    Thanked by 1netomx
  • i just got the same problem:

    [emerg]: socket() [::]:80 failed (97: Address family not supported by protocol)

    my server doesn't have IPv6 so i don't need it. to fix this look for this option on your nginx vhost configuration:

    listen [::]:80;

    and comment it out (add # in front of it) then restart nginx

Sign In or Register to comment.