Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


New on LowEndTalk? Please Register and read our Community Rules.

All new Registrations are manually reviewed and approved, so a short delay after registration may occur before your account becomes active.

Problem with ".in-addr.arpa domain name pointer"

Hi, I am having difficulty in setup a Hadoop networks (with http://cloudera.com) on some of my VPSs.

The log shows:

Detecting Cloudera Manager Server...
BEGIN host -t PTR 172.245.215.28
28.215.245.172.in-addr.arpa domain name pointer .
END (0)
using as scm server hostname
BEGIN which python
END (0)
/usr/bin/python
BEGIN python -c 'import socket; import sys; s = socket.socket(socket.AF_INET); s.settimeout(5.0); s.connect((sys.argv[1], int(sys.argv[2]))); s.close();' 7182
Traceback (most recent ca

ll last):

File "", line 1, in
IndexError: list index out of range
END (1)
could not contact scm server at :7182, giving up
waiting for rollback request

You can see the cause of failure

28.215.245.172.in-addr.arpa domain name pointer .

In other VPS, the problem is
"198.49.72.173.in-addr.arpa domain name pointer 198-49-72-173.static.dimenoc.com".

But cloudera said "198-49-72-173.static.dimenoc.com" is not accessible.

Could you please give some hints regarding network resolving?

Thanks

Comments

  • jarjar Patron Provider, Top Host, Veteran
    edited September 2013

    Have your host set your rDNS to match a working forward DNS entry. It appears to me that this is simply attempting to perform a forward confirmed reverse DNS check. You can read more about how these work at the link below.

    http://en.wikipedia.org/wiki/Forward-confirmed_reverse_DNS

  • Thanks for quick answer @jarland

    I am working on rDNS now and come back with the result.

  • Make sure the name you are trying to point to ends in a .

    If the . is missing then it will fail also.

    So it needs to be 198-49-72-173.static.dimenoc.com.

Sign In or Register to comment.