Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


New on LowEndTalk? Please Register and read our Community Rules.

All new Registrations are manually reviewed and approved, so a short delay after registration may occur before your account becomes active.

Running caddy on a nat vps

MultiMulti Veteran

Hey guys,

I am trying to run caddy on a nat vps but it seems like I am missing something, I cannot run it with https, http is working already.

My caddyfile:

http://mydomain:50865
log ./access.log
errors ./errors.log
browse
root ./public

How can I enable https? When I try to change the http to https I get the following error:

Activating privacy features...2017/07/31 12:16:36 [mydomain] failed to get certificate: acme: Error 400 - urn:acme:error:connection - Timeout
Error Detail:
        Validation for mydomain:443
        Resolved to: myip
        Used: myip

Thanks in advance.

Comments

  • edfoxedfox Member

    It is obviously trying to validate it on port 443, that you probably don't have forwarded to your vps.

  • MultiMulti Veteran

    Yeah I see that aswell. But my problem is how to change that port to one I have forwarded?

  • Lets encrypt doesnt do custom ports. Port 80 or 443 is what you need.

    You can try a proxy if your provider has that available. Or go ipv6 only.

    Thanked by 1Multi
  • cassacassa Member

    You have to get a Let's Encrypt certificate manually using the DNS-01 challenge.

    Thanked by 1Multi
  • Or ask your provider to forward your traffic on port 80 based on hostname so you can validate over port 80 instead.

Sign In or Register to comment.