Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


In this Discussion

New on LowEndTalk? Please Register and read our Community Rules.

All new Registrations are manually reviewed and approved, so a short delay after registration may occur before your account becomes active.

Proxmox error need help: pveproxy failed to start: (Result: timeout)

haruharu Member
edited May 2017 in Help

Hi there,

I have cluster with 3 nodes, all have production VMs. on node 3, i tried resize ZFS LXC, command showed timeout, but ssh into LXC i see it acctually resized. After that, node 3 showed offline on GUI while i still can ssh into it. Some of LXC on it still running, some offline.

I tried reboot node 3 but nothing change, then i tried restart pveproxy in it but command failed as bellow

systemctl status pveproxy

●pveproxy.service - PVE API Proxy Server
Loaded: loaded (/lib/systemd/system/pveproxy.service; enabled) Active: failed (Result: timeout) since Thu 2017-05-25 17:31:15 CEST; 2min 10s ago Main PID: 3753 (code=exited, status=0/SUCCESS)

May 25 17:28:14 n3 systemd[1]: pveproxy.service start operation timed out. Terminating. May 25 17:29:45 n3 systemd[1]: pveproxy.service stop-final-sigterm timed out. Killing. May 25 17:31:15 n3 systemd[1]: pveproxy.service still around after final SIGKILL. Entering failed mode. May 25 17:31:15 n3 systemd[1]: Failed to start PVE API Proxy Server. May 25 17:31:15 n3 systemd[1]: Unit pveproxy.service entered failed state.

pveversion -v

proxmox-ve: 4.4-88 (running kernel: 4.4.62-1-pve) pve-manager: 4.4-13 (running version: 4.4-13/7ea56165) pve-kernel-4.4.62-1-pve: 4.4.62-88 lvm2: 2.02.116-pve3 corosync-pve: 2.4.2-2~pve4+1 libqb0: 1.0.1-1 pve-cluster: 4.0-50 qemu-server: 4.0-110 pve-firmware: 1.1-11 libpve-common-perl: 4.0-95 libpve-access-control: 4.0-23 libpve-storage-perl: 4.0-76 pve-libspice-server1: 0.12.8-2 vncterm: 1.3-2 pve-docs: 4.4-4 pve-qemu-kvm: 2.7.1-4 pve-container: 1.0-100 pve-firewall: 2.0-33 pve-ha-manager: 1.0-40 ksm-control-daemon: 1.2-1 glusterfs-client: 3.5.2-2+deb8u3 lxc-pve: 2.0.7-4 lxcfs: 2.0.6-pve1 criu: 1.6.0-1 novnc-pve: 0.5-9 smartmontools: 6.5+svn4324-1~pve80 zfsutils: 0.6.5.9-pve15~bpo80

pvecm status

Quorum information
------------------
Date: Thu May 25 17:35:41 2017
Quorum provider: corosync_votequorum
Nodes: 3
Node ID: 0x00000003
Ring ID: 1/220
Quorate: Yes

Votequorum information
----------------------
Expected votes: 3
Highest expected: 3
Total votes: 3
Quorum: 2
Flags: Quorate

Membership information
---------------------- Nodeid Votes Name 0x00000001 1 172.16.1.1 0x00000002 1 172.16.1.2 0x00000003 1 172.16.1.3 (local)

screenshot from GUI

command resize still show loading from GUI (after 12hours)

Please help,

Thank for your time

Thanked by 1samipy

Comments

Sign In or Register to comment.