Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


New on LowEndTalk? Please Register and read our Community Rules.

All new Registrations are manually reviewed and approved, so a short delay after registration may occur before your account becomes active.

MySQL Keep telling me this in error log - Access denied for user...

xrzxrz Barred
edited April 2017 in Help

2017-04-12T13:45:50.851335Z 3 [Note] Access denied for user 'root'@'localhost' (using password: NO)

How the hell i see this in my error log if i can do mysql -u root -p and can login without any problems ? but php-mysql can not connect also? any idea?

Comments

  • raindog308raindog308 Administrator, Veteran

    xrz said: i can do mysql -u root -p and can login

    xrz said: using password: NO

  • xrzxrz Barred

    no i mean, even if i DONT login into mysql, and just do service mysql restart its there that error "[Note] Access denied for user 'root'@'localhost' (using password: NO)" after few lines where it says mysql starting etc etc ...

  • xrzxrz Barred

    i am like wtf now really

    reinstalled mysql and now:

    -- Unit mysql.service has begun starting up.

    Apr 12 17:46:02 xxx audit[12883]: AVC apparmor="DENIED" operation="open" profile="/usr/sbin/mysqld" name="/proc/12883/status" pid=12883 comm="mysqld" requested_mask="r" denied_mask="r" fsui
    Apr 12 17:46:02 xxx audit[12883]: AVC apparmor="DENIED" operation="open" profile="/usr/sbin/mysqld" name="/sys/devices/system/node/" pid=12883 comm="mysqld" requested_mask="r" denied_mask="
    Apr 12 17:46:02 xxx audit[12883]: AVC apparmor="DENIED" operation="open" profile="/usr/sbin/mysqld" name="/proc/12883/status" pid=12883 comm="mysqld" requested_mask="r" denied_mask="r" fsui
    Apr 12 17:46:02 xxx kernel: audit: type=1400 audit(1492011962.106:8423): apparmor="DENIED" operation="open" profile="/usr/sbin/mysqld" name="/proc/12883/status" pid=12883 comm="mysqld" requ
    Apr 12 17:46:02 xxx kernel: audit: type=1400 audit(1492011962.106:8424): apparmor="DENIED" operation="open" profile="/usr/sbin/mysqld" name="/sys/devices/system/node/" pid=12883 comm="mysql
    Apr 12 17:46:02 xxx kernel: audit: type=1400 audit(1492011962.106:8425): apparmor="DENIED" operation="open" profile="/usr/sbin/mysqld" name="/proc/12883/status" pid=12883 comm="mysqld" requ
    Apr 12 17:46:02 xxx systemd[1]: mysql.service: Main process exited, code=exited, status=1/FAILURE

  • Disable apparmor, problem solved.

  • xrzxrz Barred

    service apparmor stop

    after mysql restart:

    Apr 12 20:02:56 xxx audit[9838]: AVC apparmor="DENIED" operation="open" profile="/usr/sbin/mysqld" name="/proc/9838/status" pid=9838 comm="mysqld" requested_mask="r" denied_mask="r" fsuid=1

    Apr 12 20:02:56 xxx audit[9838]: AVC apparmor="DENIED" operation="open" profile="/usr/sbin/mysqld" name="/sys/devices/system/node/" pid=9838 comm="mysqld" requested_mask="r" denied_mask="r"
    Apr 12 20:02:56 xxx audit[9838]: AVC apparmor="DENIED" operation="open" profile="/usr/sbin/mysqld" name="/proc/9838/status" pid=9838 comm="mysqld" requested_mask="r" denied_mask="r" fsuid=1
    Apr 12 20:02:57 xxx kernel: audit: type=1400 audit(1492020176.998:533): apparmor="DENIED" operation="open" profile="/usr/sbin/mysqld" name="/proc/9838/status" pid=9838 comm="mysqld" request
    Apr 12 20:02:57 xxx kernel: audit: type=1400 audit(1492020176.998:534): apparmor="DENIED" operation="open" profile="/usr/sbin/mysqld" name="/sys/devices/system/node/" pid=9838 comm="mysqld"
    Apr 12 20:02:57 xxx kernel: audit: type=1400 audit(1492020176.998:535): apparmor="DENIED" operation="open" profile="/usr/sbin/mysqld" name="/proc/9838/status" pid=9838 comm="mysqld" request
    Apr 12 20:02:57 xxx systemd[1]: mysql.service: Main process exited, code=exited, status=2/INVALIDARGUMENT

  • xrzxrz Barred

    Now getting a lot of those

    2017-04-12T18:32:22.841165Z 66 [Warning] InnoDB: Cannot open table somedatabase/sometable from the internal data dictionary of InnoDB though the .frm file for the table exists. Please refer to http://dev.mysql.com/doc/refman/5.7/en/innodb-troubleshooting.html for how to resolve the issue.

  • xrzxrz Barred

    mysql is crap above fixed now getting those :D

    mysql> ALTER TABLE userseries IMPORT TABLESPACE;

    ERROR 1808 (HY000): Schema mismatch (Table has ROW_TYPE_DYNAMIC row format, .ibd file has ROW_TYPE_COMPACT row format.)

    i tried to swith that into compact at first run, the error was the same but switched :D like wtf

    before
    ERROR 1808 (HY000): Schema mismatch (Table has ROW_TYPE_COMPACT row format, .ibd file has ROW_TYPE_DYNAMIC row format.)

    now

    ERROR 1808 (HY000): Schema mismatch (Table has ROW_TYPE_DYNAMIC row format, .ibd file has ROW_TYPE_COMPACT row format.)

  • WSSWSS Member

    I never thought I'd suggest BTrieve, but you should look into that.

Sign In or Register to comment.