Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


New on LowEndTalk? Please Register and read our Community Rules.

All new Registrations are manually reviewed and approved, so a short delay after registration may occur before your account becomes active.

CentOS 6.8 (64bit) and CentOS 7.2 (64bit) will not work with FTP/Virtualmin

myhkenmyhken Member

Had some strange issues last days, and I can't seem to find the solution.
I have always used CentOS and Virtualmin/Webmin and have lots of servers running with that setup.

The first issue started with CentOS 7.2. I just yum update, then installed virtualmin from this guide: (Guide ) Everything seems OK, but the PRO FTP server will not run, just getting error messages.

I have seen the same issue some time ago, then it was something with the hostname and actual IP. But this time hostname have the correct IP.

OK, I then installed virtualmin on a new/clean server with CentOS 6.8, and the same issue happened there. ProFTP will not start. Every other service is OK.

Someones that know what I'm is missing here?

Comments

  • myhken said: the PRO FTP server will not run, just getting error messages.

    I am turning on my phone and just getting error messages.

    Somes that know what I'm missing here?

  • myhkenmyhken Member

    It's only on the CentOS 7.2 I get error messages, but I don't have a 7.2 installation just now. On CentOS 6.8 ProFTP will just not start.
    The 7.2 server is a Online.net dedicated the 6.8 is a Kimsufi dedicated. Tried two Kimsufi servers, but the same error.

    Port 21 is not blocked, for it working fine on Windows Server on the same machines.

  • I have CentOS 6.8 running proftp on a Digital Ocean droplet without issue. It would be helpful if you posted the error message from /var/log/proftpd or /var/log/messages.

  • I've encountered the same issue. You have to manually un-install proftpd and install it again and it will work.

    Thanked by 1myhken
  • ElnarRElnarR Member

    Agree with chasewalsh. I had the same problem and reinstalling of proFTPd resolved it.

  • myhkenmyhken Member

    I tried to remove, then reinstall ProFTP on CentOS 7.2, but that did not help.
    I got ProFTP to work on CentOS 6.8, it's seems like maybe one of my dedicated servers from Kimusfi has a block on port 21 or something (strange since it work with Windows Server). But on the second server I tried it worked without any issue.

Sign In or Register to comment.