Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Need some help on ipv6 on dacentec
New on LowEndTalk? Please Register and read our Community Rules.

All new Registrations are manually reviewed and approved, so a short delay after registration may occur before your account becomes active.

Need some help on ipv6 on dacentec

wlambrechtswlambrechts Member
edited September 2016 in Help


I have a dacentec server with debian 8 (on which I installed Proxmox), and can't seem to enable ipv6 on it (just ipv6 connection to the host).

I have been trying to set it up for hours without success and dacentec supports can only send me some general URL's but they assured me ipv6 should be working and it is caused by a malconfiguration

This is what I set up (address modified)

I received a /48 address: 1:2:3::1

I set up /etc/network/interfaces as follows:

iface eth0 inet6 static address 1:2:3::2 network 1:2:3::/48 gateway 1:2:3::1

The settings for the network and gateway were 'hinted' by support.

on the server itself

  • ping6 1:2:3::2 does respond
  • ping6 1:2:3::1 does not repond (network is unreachable)
  • ping6 does not respond (network is unreachable)

externally (

  • ping6 1:2:3::1 responds
  • ping6 1:2:3::2 does not respond

This is what ip 6 -a tells me:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1 inet6 ::1/128 scope host valid_lft forever preferred_lft forever 2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000 inet6 1:2:3::2/128 scope global valid_lft forever preferred_lft forever inet6 fe80::225:90ff:fe10:7810/64 scope link valid_lft forever preferred_lft forever

Any help is greatly appreciated !



  • rm_rm_ IPv6 Advocate, Veteran
    edited September 2016

    Try replacing network 1:2:3::/48 with netmask 48.

    Also what is your gateway after all, 1:2:3:: or 1:2:3::1? May need to check that as well.

    Thanked by 1wlambrechts
  • thanks rm_

    I was told the gateway was 1:2:3::1
    I also tried netmask 48. Both, unfortunately, to no avail...

  • AutoSnipeAutoSnipe Member
    edited September 2016

    iface etho0 -> iface eth0


    iface eth0 inet6 static
    address 1:2:3::4
    netmask 48
    gateway 1:2:3::1
    Thanked by 1wlambrechts
  • Thanks @AutoSnipe, but it was a typo in my message, it was/is correct on the server.

  • rm_rm_ IPv6 Advocate, Veteran
    edited September 2016

    @wlambrechts if you set as shown in the @AutoSnipe's message (and of course restart networking or reboot), can you then ping 1:2:3::1 from the server? Paste ip -6 a again, and ip -6 r.

    Thanked by 1wlambrechts
  • thanks @rm_ and @autosnipe ! You solved my problem !

    The correct section is indeed:

    iface eth0 inet6 static address 1:2:3::2 netmask 48 gateway 1:2:3::1

    I had tried the "netmask" but at the time my gateway was not set up correctly !

Sign In or Register to comment.