Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Anyone with experience migrating existing server to Linode?
New on LowEndTalk? Please Register and read our Community Rules.

Anyone with experience migrating existing server to Linode?

rchurchrchurch Member

I have trying to migrate an existing vultr server to Linode and haven't had much luck.

I basically created a disk, transferred the data, and configured grub expecting it to boot, but it always failed, something I have never experienced in migrating KVM systems among different LEB providers. I find their Finnix recovery disk awkward compared with System Rescue CD.
I know their system isn't the regular Solus supported KVM or OpenStack but it should be able to work in principle. My idea is to get System Rescue CD running form a hard disk then start using it configure any new systems I want.

Does anyone have real experience doing this on Linodes? I have tried their tutorials but still had problems.

Here are the points I needs some help with.

  1. Install an older 32bit system

  2. Transfer an existing server from another provider to a Linode. ie transfer the fiiles, configure grub and get it boot.

  3. Install any Linux OS from a CD-ROM, ie mount the CD-ROM and boot from it

  4. Transfer a qcow or vmdk image onto a disk and get it to boot.



  • yomeroyomero Member

    For your 1, 3 and 4. AFAIK they don't support isos, and they just have 64 bit templates. Maybe you can debootstrap or something, but that's all I think.

    Also, I guess you are already switched to the new KVM instances right? Double check your instance type because maybe you are still on Xen.

    And for the Grub to work, you need to switch your configuration profile to Direct disk, otherwise the system will try to boot the linode kernel instead of yours

    Thanked by 1rchurch
  • @yomero I am using KVM instances and booting from Direct Disk and I am still have problems. Even when I boot to Grub and try to start it interactively, the screen is useless with the cursor and text all over the place.
    Have you tried it before and succeeded?

Sign In or Register to comment.