Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Turning VNC off on KVM VPS
New on LowEndTalk? Please Register and read our Community Rules.

All new Registrations are manually reviewed and approved, so a short delay after registration may occur before your account becomes active.

Turning VNC off on KVM VPS

daviddavid Member
edited October 2012 in Help

I'm used to working with xen, openvz, and vmware. I just got my first KVM VPS from prometeus.

After installing the OS (CentOS 6) I wanted to disable/turn off VNC, since it seems like it's a security risk to leave it enabled all the time. I can turn it off in the SolusVM settings, but after I do that and reboot, it doesn't boot anymore.

Any idea how I can disable VNC and still let the VPS boot? Does everybody just leave it enabled all the time? 8 character VNC passwords would be relatively easy to brute force.


  • I keep VNC enabled only during OS installation.

    I have a KVM with Prometeus as well. I always disabled VNC after install, no problem at all.

    Maybe something else's the matter with your VPS ... ?

  • Interesting... Maybe it's something with CentOS. Are you running CentOS 6?

  • No ... I'm running Debian 6 x86 . :(

    Are you sure turning off VNC was the only thing you changed before rebooting (that rendered the VPS unbootable) ?

    Thanked by 1david
  • Yeah, I just tried it again. I rebooted, logged in & out fine, then turned off VNC from SolusVM and rebooted again, and it's dead (not even pingable). It does show as online from SolusVM, though.

  • kvm with prometeus and vnc turned off, no problem here too. Using debian squeeze.

    Thanked by 1david
  • @david perhaps your centos build doesn't boot if it doesn't see a console attached. perhaps google for "headless" centos advice...

    Thanked by 1david
  • Thanks for the ideas. I compared the grub.conf file to the grub.conf file on a xen vps and found 2 extra lines. After removing these 2 lines, it's able to boot with VNC turned off:


Sign In or Register to comment.