Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Problem with reciveing GET parameter over HTTPS
New on LowEndTalk? Please Register and read our Community Rules.

All new Registrations are manually reviewed and approved, so a short delay after registration may occur before your account becomes active.

Problem with reciveing GET parameter over HTTPS

Hi, i am a developer and currently i am working on a app using Laravel 4.2. I am hosting the app on my local webserver, and i am using Nginx as a webserver.
The problem is that i cannot get the parameters from a GET request, in Laravel, if i do a dd(Input::all()); there is no variables there, the POST method works, and i remember that without SSL the GET parameters are there.
Can someone help with this?


  • At your Nginx : /etc/nginx/fastcgi.conf or fastcgi_params, try to modify this line

    fastcgi_param HTTPS $https if_not_empty;

    Try to make it off

  • I have tried, with on; off; and the default setting, but still no response.

  • I have tried also without https, and it dose not work.

  • I found the problem, and here is the result:
    location / {
    try_files $uri $uri/ /index.php?$query_string;

  • telephonetelephone Member
    edited April 2015

    slave2anubis said: I have tried also without https, and it dose not work.

    Can you paste your Nginx config (blank out your IP and other personal details)? It will be a lot quicker that way, instead of making countless suggestions.

    Quickly though, here's one of the most common errors:

    #1) In your try_files, do you have $query_string? Example:

    location / { try_files $uri $uri/ /index.php?$query_string; }

    Edit: Nevermind. It looks like you figured it out while I was waiting for LET to load.

Sign In or Register to comment.