Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Weird Errors
New on LowEndTalk? Please Register and read our Community Rules.

Weird Errors

InfinityInfinity Member, Host Rep
edited December 2012 in Help

Hey Guys,

Either I'm getting weird errors that I cannot think of a solution in a million years or I'm plain stupid, most likely the latter. Anyhow, I recently tried to login to my DirectAdmin server and found the "admin" user's password to be incorrect, the obvious thing to do after trying every single password and asking my partner who has access too was to reset the password.

A relatively simple task, you'd think. This is for all those brainboxes out there, When I tried to reset the password, I got the following message:

[[email protected] ~]# passwd admin
Changing password for user admin.
passwd: Authentication token manipulation error

I did a bit of reasearch on Professor Google's site and found out that it could indicate a problem with the shadow and passwd file mirroring. Sure enough there was no entry for admin in /etc/shadow so I proceeded to run the magical "pwconv" only to find that has an error two. One that looks simple to me but I cannot figure out:

pwconv: can't lock passwd file 

It looks to me as if that is a permissions problem but I don't see what kind of permissions problem.

Can anyone enlighten me on a possible solution?


  • are you able to login to the admin user via su - admin ?

  • InfinityInfinity Member, Host Rep
    edited October 2011

    Nope, tried that. I should've menitioned that I've tried that already. I have a feeling that something is corrupted but backing up all clients manually will be a nightmare.

    I could, I guess if all else fails contact DirectAdmin support but that's long.

  • sorry, I don't know much about DirectAdmin as I've never used it before, but try seeing if the admin user actually exists? cat /etc/passwd

  • InfinityInfinity Member, Host Rep

    Yeah, it isn't really my speciality too. I only got donated the license recently.

    [[email protected] ~]# grep admin /etc/passwd
  • KuroKuro Member
    edited October 2011


    I think that may explain why you can't login to admin user via su - admin

  • kiloservekiloserve Member
    edited October 2011

    Infinity said: admin:x:501:501::/home/admin:/bin/false

    Change that to /bin/bash or wherever your bash is on your system and then try logging in as admin. And if you can login as admin, do your passwd change.

    Other things to check:
    1) Are you out of disk space?  I've seen this happen on systems with 100% disk usage.  df -h
    2) Is there an /etc/passwd.lock or /etc/shadow.lock file?
    3) Do you have any other running processes by the admin user?
  • InfinityInfinity Member, Host Rep

    Yep, I know /bin/bash is the normal option however I presumed it was a DirectAdmin thing.

    1) Indeed, you are a psycho, I am at 100% disk usage and I need to login to backup one thing then I was going to do a full reinstall.

    2) Not when I last checked but I cannot login to SSH to confirm.

    3) Not when I last checked.

    At first I thought that the server has been hacked or compromized however I cannot login to root or change the password on SolusVM, I cannot login via the SolusVM console which indicates to me something on TailoredVPS's side.

  • kiloservekiloserve Member
    edited October 2011

    Infinity said: I am at 100% disk usage

    If you're at 100% disk usage, you won't be able to change your password as the system needs space to write the lock file. Free up some space and then you can change all the passwords you want and even login :)

    If you are completely unable to login to erase files, ask your VPS provider to manually delete some files for you that you can specify.

    No need to reformat just for this unless you just want a clean install again.

  • I guess you can login via vzctl.

    Also, I miss that feature in HyperVM to manage the files

  • InfinityInfinity Member, Host Rep
    edited October 2011

    @kiloserve I just formatted it since I couldn't login to root, nor console and I didn't have time to deal with the provider. It also seems like their CentOS templates are a bit messed up.

    @yomero Yeah, thats where it would come in useful. HyperVM <3

  • InfinityInfinity Member, Host Rep
    edited October 2011

    Okay, this is pretty wierd. The exact same thing happened to my cPanel server except it's no where near the disk limit. I just cannot login to SSH or change the root password or login to the console. Any ideas, they are on different providers.

    Damn, this is wierd. Must be something like fail2ban blocking me. I can connect via my hostigation vps.

  • By any luck are you using OpenVZ once I had that problem and it was due to a bad template file.

  • InfinityInfinity Member, Host Rep

    Yep, OpenVZ and yes all the CentOS templates are broken.

  • Before proceeding any other changes check whether there is any attribute set for /etc/passwd or /etc/shadow

    lsattr /etc/passwd
    lsattr /etc/shadow

  • flyfly Member

    why are you necro'ing these threads?

  • October 2011. Really?

  • Now that he has 5 posts, incoming sales thread from in 3, 2, 1, GO!

  • flyfly Member

    could have just "trolled" in daniel's tinfoilhat thread and gotten that post count

    Thanked by 1DanielM
  • DanielMDanielM Member
    edited August 2012

    @fly said: could have just "trolled" in daniel's tinfoilhat thread and gotten that post count

    Dude wtf?

    Oops said Thanks by accident :( should have clicked flag

  • @gsrdgrdghd said: Now that he has 5 posts, incoming sales thread from in 3, 2, 1, GO!

    And boom!

    I was 3 minutes off :(

  • InfinityInfinity Member, Host Rep

    Dafuq, this is a bit random..

Sign In or Register to comment.