Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

FTP transferred 0 bytes
New on LowEndTalk? Please Register and read our Community Rules.

FTP transferred 0 bytes

libro22libro22 Member
edited September 2011 in Help

First, let me introduce my setup for ServerB:

  • default installation of CSF and base
  • using VSFTPD server with the following configuration:
  • disabled httpd cause i'm not using it

I'm using a script to FTP files from another server to ServerB. This script has been working for the past 4 months and has been successfully transferring files to another server I've been using before.

This is the first time the script transfers 0 bytes of files. I've tried using both passive and active ftp but none works.

I read VSFTPD's log file - the script is able to login but once the file begins to transfer, it returns "Failed to establish connection".

Where do you think is the problem (vsftpd config, firewall, etc.)?

Thank you.


  • What about permissions? Maybe? :P

  • Isn't there anything in an error or system log?

  • kiloservekiloserve Member
    edited September 2011

    Just some ideas:

    1) Permission issues. Where are you uploading files to? Make sure that the destination folder is owned by the same ftp user.

    2) Firewall issues. SPI Firewalls are the bane of FTP since the port used can be dynamic. ip_conntrack and ip_conntrack_ftp should be enabled if possible. In addition you may need to open a range in the high end ports. Try to temporarily disable your firewall to see if it is the one causing the problems.

    3) Try switching between ACTIVE and PASV connections.

  • libro22libro22 Member
    edited September 2011

    how do i enable ip_conntrack and ip_conntrack_ftp modules?

    i'm sure there are no issues with permissions and active/passive cause i tried them transferring with different methods and it works.

    i'm guessing it's the firewall and the modules.. i did a new OS reinstall and decided not to use CSF and iptables firewall at the moment just to check..

    do you think it has something to do with httpd off?

    thank you.

  • ^

    @xeoncross - vsftpd log does not show any significant message, just that when the file begins to transfer, the connection is disconnected for unknown reasons :( i also don't know yet how to read vsftpd logs, there are numbers beside each log message so i guess that's the client id..

Sign In or Register to comment.