Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Exim on VestaCP rejects sending email from remote desktop client
New on LowEndTalk? Please Register and read our Community Rules.

Exim on VestaCP rejects sending email from remote desktop client

thekreekthekreek Member
edited February 2014 in Help

Hello, currently I have a VestaCP install, it's able to send and receive emails from the webmail (roundcube) however when I try to send any email from a Desktop client (Mozilla Thunderbird or MS Outlook) the mail gets rejected.

I always get the following message:
An error occurred while sending mail. The mail server responded: Helo name contains a ip address (HELO was [192.168.1.50]) and not is valid. Please verify that your email address is correct in your mail preferences and try again.

I have checked the exim logs and they show the same error, the only difference is that they show 2 IP’s (WAN IP and local IP, the computer is behind a router). This problem happens every time a user try’s to send an email and he/she is behind a router.
I have tested the 2 local ISP’s with different router’s and it’s the same issue.

The only addition I made to my install, was installing CSF. I have tested disabling CSF, rebooting the server and the problem persists.

Do you have any suggestions or possible fix?

Comments

  • DavidxDavidx Member
    edited February 2014

    CSF caused quite a headache with somethings in Vesta.

    I know you said you disabled it, but did you disable it this way?

    nano /etc/csf/csf.conf

    Change TESTING = "0" to TESTING = "1"

    csf -r

  • jarjar Member, Patron Provider
    edited February 2014

    Edit /etc/exim/exim.conf

    Look for this:

      drop    message   = Helo name contains a ip address (HELO was $sender_helo_name) and not is valid
              condition     = ${if match{$sender_helo_name}{\N((\d{1,3}[.-]\d{1,3}[.-]\d{1,3}[.-]\d{1,3})|([0-9a-f]{8})|([0-9A-F]{8}))\N}{yes}{no}}
              condition     = ${if match {${lookup dnsdb{>: defer_never,ptr=$sender_host_address}}\}{$sender_helo_name}{no}{yes}}
              delay         = 45s

    Comment that out, restart exim.

    Thanked by 2thekreek Amitz
  • @David_P already did it and still the same problem.

    @jarland i'm using Debian 7, already look at /etc/exim4/conf.d I search each directory and file and I didn't find that line.

  • jarjar Member, Patron Provider

    @thekreek said:
    David_P already did it and still the same problem.

    jarland i'm using Debian 7, already look at /etc/exim4/conf.d I search each directory and file and I didn't find that line.

    Hmm.

    grep -R "Helo\ name\ contains" /etc

  • thekreekthekreek Member
    edited February 2014

    @jarland thanks I found the line on the file exim4.conf.template, but the lines are already commented out.

    There aren't more results with grep.

    A bit of search on the git from vesta, I have the same config: https://github.com/serghey-rodin/vesta/blob/master/install/debian/exim4.conf.template

  • jarjar Member, Patron Provider

    Installing on debian 7 real quick, admittedly never ran exim on there so maybe something a little different than I expect.

  • jarjar Member, Patron Provider

    thekreek said: I found the line on the file exim4.conf.template, but the lines are already commented out.

    Alright I installed it on Debian 7 just now. On mine those lines weren't commented out. Maybe check this one too:

      drop
              condition     = ${if isip{$sender_helo_name}}
              message       = Access denied - Invalid HELO name (See RFC2821 4.1.3)
  • @jarland did you find those lines in the same file?

  • jarjar Member, Patron Provider

    @thekreek said:
    jarland did you find those lines in the same file?

    Yeah, just a few lines down.

  • @jarland just found the new line, and it's also already commentd out.

  • @jarland I just made a comparision between my exim4.conf.template and the one on git (https://github.com/serghey-rodin/vesta/blob/master/install/debian/exim4.conf.template) and it's the same.

    Both configs are already commented out.

  • jarjar Member, Patron Provider

    @thekreek said:
    jarland I just made a comparision between my exim4.conf.template and the one on git (https://github.com/serghey-rodin/vesta/blob/master/install/debian/exim4.conf.template) and it's the same.

    Both configs are already commented out.

    Hmm, here's the relevant portion on mine on a fresh install just now. Adding in the rules before and after it. I'm a bit confused because this is definitely what should be generating that error. So if the part if this that isn't commented in my paste below is commented in yours and exim has been started since that happened, I'm really confused why it's still doing it :(

    #  drop
    #          condition     = ${if isip{$sender_helo_name}}
    #          message       = Access denied - Invalid HELO name (See RFC2821 4.1.3)
      drop    message       = Helo name contains a ip address (HELO was $sender_helo_name) and not is valid
              condition     = ${if match{$sender_helo_name}{\N((\d{1,3}[.-]\d{1,3}[.-]\d{1,3}[.-]\d{1,3})|([0-9a-f]{8})|([0-9A-F]{8}))\N}{yes}{no}}
              condition     = ${if match {${lookup dnsdb{>: defer_never,ptr=$sender_host_address}}\}{$sender_helo_name}{no}{yes}}
              delay         = 45s
    #  drop
    #          condition     = ${if match{$sender_helo_name}{\N^\[\N}{no}{yes}}
    #          condition     = ${if match{$sender_helo_name}{\N\.\N}{no}{yes}}
    #          message       = Access denied - Invalid HELO name (See RFC2821 4.1.1.1)
  • jarjar Member, Patron Provider

    Actually I just hit the git one, I think you may be looking at the wrong portion for the comment. Check mine above there, looks like the git version. Each line that isn't commented there needs to be commented.

  • @jarland The only section I found that has those settings is acl_check_mail (my config)

  • jarjar Member, Patron Provider

    @thekreek said:
    jarland The only section I found that has those settings is acl_check_mail (my config)

    Correct. Comment those four lines, restart exim, problem gone :)

  • @jarland I just sended you a PM with a link, can you look at it.
    Thanks.

  • @jarland thanks this worked at a 100

    Thanked by 1jar
  • support123support123 Member
    edited February 2014

    @jarland is a real helpful guy. +1 for him .He helped me before as well

Sign In or Register to comment.