Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


A quick guide for setting up Windows on the new Kimsufi range
New on LowEndTalk? Please Register and read our Community Rules.

A quick guide for setting up Windows on the new Kimsufi range

sc754sc754 Member
edited February 2014 in Tutorials

Hi all,

After messing around with my new kimsufi PS19 server I decided to write a short guide on how to set up windows on it for those that want to since the new range doesn't have a windows install option.

The way to install windows is quite simple, you just need to install the proxmox OS, create a VM (KVM) and then install Windows as normal. Finally since the server has an ipv4 limitation you need to setup an internal lan ip and route external ports to it (for control through remote desktop or VNC or whatever you want to use). It's quite straight forward to setup external internet access for the Windows KVM vps you create since you can just follow the instructions here: http://help.ovh.co.uk/Proxmox under the section "create a vm nat".

So to begin with... install VPS Proxmox VE 3.1 (64bits) on your kimsufi control panel. Now login with ssh / putty to your kimsufi server. Once in go to the folder

/var/lib/vz/template/iso/

and either upload or wget your Windows Server (or other OS) template iso into that folder. For mine, I registered for the 180 day Windows Server 2008 license and used wget to download the iso direct from the Microsoft site. You'll also want to download the virtuo drivers ISO which at the time of writing can be found at:

https://alt.fedoraproject.org/pub/alt/virtio-win/latest/images/bin/virtio-win-0.1-74.iso

Ok so that's the iso's done.

Now before making the VM you'll want to create the vmbr2 bridge as per the tutorial at OVH. It's quite straightforward if you just edit using vi or nano the file

/etc/network/interfaces

and add to the bottom:

auto vmbr2

iface vmbr2 inet static

address 192.168.0.254

netmask 255.255.255.0

bridge_ports none

bridge_stp off

bridge_fd 0

post-up echo 1 > /proc/sys/net/ipv4/ip_forward

post-up iptables -t nat -A POSTROUTING -s '192.168.0.0/24' -o vmbr0 -j MASQUERADE

post-down iptables -t nat -D POSTROUTING -s '192.168.0.0/24' -o vmbr0 -j MASQUERADE

Now do this in ssh to bring the bridge up:

ifup vmbr2

This will create a virtual LAN you can use to assign IP's to your Windows (or other KVM OS) system. You can assign any ip within 192.168.0.1 - 192.168.0.253.

Ok so the next thing is to create your Windows KVM.

Login to your proxmox control panel at: https://your.ip:8006, and login with your root user and password. Now go to "create VM". Assign it whatever VPSID you want, now go to the next tab (OS) and select win2k8. Next go to CD/DVD and select the windows ISO image you uploaded earlier (not the virtuo drivers one yet!). Next comes the hard disk, set the BUS to VIRTIO and also set the disk size to whatever size you want it to be, everything else can be left as default. Now go to CPU and set the number of CPU Cores you want the Windows KVM to have access to, sockets should almost always be 1. Be sure to set the Type to "host" as well, so your Windows KVM has full access to your CPU's extensions. Next go to memory and set the amount of ram you want Windows to have (I recommend at least 1.5GB).

This next bit is important, go to the network tab and select your bridge as vmbr2 (the one you created earlier) and set the model to VIRTIO. Finally, confirm and finish. Now once it's made go find it under the node section on the left (under datacenter) and click on it, then start it up (top right). Open up console (requires java, say yes to all the pop ups or try different internet browser if it doesn't load properly).

Now to get the best drivers (VIRTIO) working you'll need to switch over the ISO your using mid installation (it won't find your HDD until you install the virtuo drivers during the Windows install). You can switch the ISO by going to the Hardware tab under your KVM in proxmox and selecting CD/DVD Drive then going back to console and refreshing on the select HDD screen of the windows install. Now to install the drivers you'll need to go to load drivers (in the console / install window) and select your ISO / Virtual Disc, open it up and choose Windows 7 / amd64 and it should find 3 drivers for you. select and install them / click next. Now switch back to your Win2k8 ISO or whatever windows version your installing, and continue the install as normal.

Once the install is done, you just need to edit your network settings to assign your KVM a private ip.
This is done by going to your desktop in console (once installed and rebooted) and finding > networking and sharing center > local area connection > properties > click TCP IPv4 > click properties. Now assign your Windows KVM a private ip selecting use the following IP address and inputting (for example - use whatever ip you want in the range discussed earlier):

ip : 192.168.0.1

subnet mask 255.255.255.0

gateway : 192.168.0.254 (ip vmbr2 on the host)

DNS: 8.8.8.8 and 8.8.4.4 (or whatever DNS you want to use, this is googles)

Click ok > ok > then close. You server should now have outside connectivity to the internet!!!

Ok so now you need to enable remote desktop in your firewall (should be easy enough to do if you know the OS well enough) and also set remote desktop to being on, you can do the latter part by going to Control Panel > system and security > system > remote settings > and allow remote desktop connections (more or less secure version) whichever you prefer.

Right, finally you'll want access to your Windows KVM desktop via remote desktop (since console is slow and not very good). To do this just login to your kimsufi server by SSH and enter the following as root:

iptables -t nat -A PREROUTING -i vmbr0 -p tcp --dport 3389 -j DNAT --to 192.168.0.1:3389

(ASSUMING your using the ip 192.168.0.1, if not changed the ip above to yours).

You should now have access to the Windows KVM from your pc over the default Remote desktop port of 3389 using the internet ip of your kimsufi server (the one OVH gave you not the 192.168 ip).

I'm not sure if I've missed anything but let me know if I have and I will update this.

Enjoy!

«1

Comments

  • sc754sc754 Member
    edited February 2014

    Note: to route the external port 3389 after a host node reboot you can add the rule into the vmbr2 section of /etc/network/interfaces as per the explanation under create vm nat from http://help.ovh.co.uk/Proxmox

  • I tried only to realize the Atom line doesn't support VT =|

  • hi, i found your guide VERY good, but i cant get remote connect to work, or any other services, then just time out. Any help or ideas?
    thanks

  • JyleeJylee Member, Provider

    I don't like VM... Is there a way to install windows on the node directly?

  • cassacassa Member, Provider
    edited February 2014

    @Jylee said:
    I don't like VM... Is there a way to install windows on the node directly?

    Not sure, but i thought you can install it using an ISO using KVM over IP

  • there is, but those that know arnt telling and charge over the odds for doing it for you

  • @casshern said:
    hi, i found your guide VERY good, but i cant get remote connect to work, or any other services, then just time out. Any help or ideas?
    thanks

    Does your outside internet work from the KVM? If it does it's probably just iptables, clear your iptables rules first then add the port forward if your outside internet access is working from the KVM.

  • @sc754 no that doesnt work either :( only things working are i can still putty to it on ssh also teamviewer works and i can browse the net while on the console in proxmox

  • @casshern said:
    sc754 no that doesnt work either :( only things working are i can still putty to it on ssh also teamviewer works and i can browse the net while on the console in proxmox

    What else did you intend to do with it? By the way you have to enable RDP in your windows server KVM. It doesn't work by default, you can enable it in control panel > system & security > system > remote settings

  • yes RDP is on, i wanted to host game servers and voip on it as i would a normal server, but nothing connects

  • @casshern said:
    yes RDP is on, i wanted to host game servers and voip on it as i would a normal server, but nothing connects

    Did you clear your iptables completely before adding the NAT forward? You also have to make sure that RDP and the other programs you want are allowed through the firewall. You can always test by disabling the windows firewall and then connecting to see if it's that that is blocking the outside connection. Make sure you forward the port to the right ip and that it's the right protocol.

  • by clear iptables, i did everything in the guide, and i did turn off the firewall :S

  • tryed again from start still no RDP and cant connect to anything ts3 minecraft etc if i run a server :S

  • @sc754 Please check your inbox. I've been messaging you since March 9 without any response. Thanks.

  • I'm confused at which ip do I need to replace with my server ip

  • @Ruriko said:
    I'm confused at which ip do I need to replace with my server ip

    Which section are you at? Your server ip will normally be the public interface ip given by your hosting provider.

  • Well I followed all the steps except I'm having trouble connecting via RDP. Lets say for example my server ip is 155.33.1.190. I have created vmbr2 with this code:
    auto vmbr2 iface vmbr2 inet static address 155.33.0.254 netmask 255.255.255.0 bridge_ports none bridge_stp off bridge_fd 0 post-up echo 1 > /proc/sys/net/ipv4/ip_forward post-up iptables -t nat -A POSTROUTING -s '155.33.0.0/24' -o vmbr0 -j MASQUERADE post-down iptables -t nat -D POSTROUTING -s '155.33.0.0/24' -o vmbr0 -j MASQUERADE

    and I have configured my windows LAN with this:
    ip : 155.33.0.190 subnet mask 255.255.255.0 gateway : 155.33.0.254 DNS: 8.8.8.8 and 8.8.4.4

    then I tried to connect RDP with ip 155.33.1.190 but didn't work so I tried again with 155.33.0.190.

    Is there anything wrong with my settings?

  • @Ruriko said:
    Well I followed all the steps except I'm having trouble connecting via RDP. Lets say for example my server ip is 155.33.1.190. I have created vmbr2 with this code:
    auto vmbr2 iface vmbr2 inet static address 155.33.0.254 netmask 255.255.255.0 bridge_ports none bridge_stp off bridge_fd 0 post-up echo 1 > /proc/sys/net/ipv4/ip_forward post-up iptables -t nat -A POSTROUTING -s '155.33.0.0/24' -o vmbr0 -j MASQUERADE post-down iptables -t nat -D POSTROUTING -s '155.33.0.0/24' -o vmbr0 -j MASQUERADE

    and I have configured my windows LAN with this:
    ip : 155.33.0.190 subnet mask 255.255.255.0 gateway : 155.33.0.254 DNS: 8.8.8.8 and 8.8.4.4

    then I tried to connect RDP with ip 155.33.1.190 but didn't work so I tried again with 155.33.0.190.

    Is there anything wrong with my settings?

    Yes, those settings should be the internal ip of the vps not the public ip like you have. You're better off using the default's I've provided of 192.168.0.1 for this first vps, copying what I have exactly.

  • After rebooting from the Kimsufi panel. It shows no hard drive at the boot time. KS-4 and WS 2012. What did I miss?

  • @sdglhm said:
    After rebooting from the Kimsufi panel. It shows no hard drive at the boot time. KS-4 and WS 2012. What did I miss?

    Did you changre from netboot to hard drive? and disabled rtm ?

  • No. I mean after rebooting the virtual machine.

  • After reboot, everything works except when loading windows on vps shows no hdd. Even after normal reboot from Vps panel

  • @sdglhm said:
    After rebooting from the Kimsufi panel. It shows no hard drive at the boot time. KS-4 and WS 2012. What did I miss?

    You have to switch over the drivers during the windows install, ie. change the cd rom iso to virtuo instead of windows then reload. Re-read that part above

  • I have installed the Virtuo Drivers. Everything works fine until reboot

  • @sdglhm said:
    I have installed the Virtuo Drivers. Everything works fine until reboot

    As in when you reboot the vps or the host?

  • Even after rebooting the VPS error does occurs

  • @sdglhm said:
    Even after rebooting the VPS error does occurs

    I don't know, I've never seen this problem nor has anyone ever asked about it. Can you send me a SS?

  • this guide can be applied to the online.net Dedibox-kidéchire server?

  • @Smbat said:
    this guide can be applied to the online.net Dedibox-kidéchire server?

    Yes.

  • and does it work? What about WinXP, if I have my license.

Sign In or Register to comment.