Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

VPS: after reboot services wont load at boot time
New on LowEndTalk? Please Register and read our Community Rules.

All new Registrations are manually reviewed and approved, so a short delay after registration may occur before your account becomes active.

VPS: after reboot services wont load at boot time

sandrosandro Member
edited March 2012 in General

I'm using a vps with ubuntu 10.04. All went smooth for months in fact I haven't had a downtime or reboot for 157 days! Today I tried to reboot and NOTHING was loaded. I basically had 1.57MB of RAM used, I have to access the vps via the SolusVM recovery console and start networking, local network (lo interface) and ssh to get things started. I thought that maybe for some strange reason all the startup services got disactivated but while checking with chkconfig they're actually all on, networking is set to load at level 0 . So why aren't they loading and more importantly what caused this?

If I try to do launch this for every service that used to start

sudo update-rc.d ssh defaults

I get

update-rc.d: warning: ssh stop runlevel arguments (0 1 6) do not match LSB Default-Stop values (none) System start/stop links for /etc/init.d/ssh already exist.

During those months I updated security packages weekly and performed some "dist-upgrade" that as far as I remember was just used to upgrade php5-fpm and mysql

The provider just told me that apparently it's a bug in ubuntu and they're looking into a way to fix or at least understand the reason.
I must say this already happened to me once with another hosting service but since I couldn't get in via solusvm console I just couldn't investigate further. Anyone experienced this?


  • What runlevel are you in?

  • tuxtux Member

    Are you running your vps on OpenVZ?

  • Didn't @KuJoe say something about not to use it? Or was that something else?

  • sandrosandro Member
    edited March 2012

    @Damain how can I check that?
    @tux yes

    It's strange no one else experienced this, I've googled it but I couldn't find anything. Maybe it happens and is easily fixable?

  • # runlevel
    N 2
  • yes N 2

  • I can't help. What I can say, is that upstart stuff is weird and I don't understand it, so Ubuntu sucks for me. In other words, me in your shoes... proceeding to reinstall.

    But maybe there are other opinions.

  • happened to me too on one of the LEB vps for testing environment. OS was centos, works great without reboot but after a down/reboot everything fails. Had to reinstall everything to get it running again. Good thing it was a test vps, i wouldn't imagine going through all that with a working environment vps.

    Providers fault? all i did was yum-update and running a few apps here and there.

  • Yes, I had issues as same from some VPS providers.
    Try this tool: sysv-rc-conf, this mayhelp you save your service runlevel.

    sudo apt-get install sysv-rc-conf

  • Go59954Go59954 Member
    edited March 2012

    I suggest you do a work around using a cron job to start the required services at once after startup, for example to run:
    /etc/init.d/httpd start
    /etc/init.d/ssh start
    /etc/init.d/mysql start

    and might work
    service servicename start

    edit: if you are able to manually run the services in ssh after startup that should work

  • sandrosandro Member
    edited March 2012

    in the end the provider fixed it. they told me it was a bug in the openvz-ubuntu installation. I'm asking more info about this issue.
    Are you saying that its openvz?

  • debian may have the same issue

  • On debian you can simply apt-get install rcconf to obtain the necessary tool.

  • i had the same issues on some vpses, rcconf can't save the configruration. try apt-get install sysv-rc-conf, and I did it successfuly.

  • well I can't test those since it's already fixed by the provider. They told me they have been referred to this url to fix it

    Thanked by 1AshleyUk
  • netomxnetomx Moderator, Veteran

    try init 3????

  • sandrosandro Member
    edited March 2012

    **Answer from support **

    how I can prevent it

    This can be prevented by adding rules in /etc/init/openvz.conf by reffering following url

  • I also got this error immediatelly after VPS boot, but after waiting a few minutes , ssh automatically started. Also if ssh not start, maybe trying manually add init.d/ssh start to locations metnioned here in replies:

  • @postcd Why are you resurrecting an old a$$ thread?

Sign In or Register to comment.