Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Help with windows VPS
New on LowEndTalk? Please Register and read our Community Rules.

Help with windows VPS

I tried setting up a VPN on my windows vps. At first it refused to even connect but I fixed that by manually entering the IP range and checking the "allow calling computer to specify it's own IP address" box.

But now when it connects I don't have internet access. Suprisingly my RDP connection to the VPS doesn't close (all other RDP connections do...)
I also noticed there is no connection on IPv4 even though I enabled it

Comments

  • Anyone know a solution?

  • rustelekomrustelekom Member, Patron Provider

    How VPN related to your Windows VPS IP address? You Windows VPS IP address should be dedicated to you by host and you cannot change it to IP's from local network. That is why you lost connection to the Internet.

  • patropatro Member

    If client is windows make sure in ipv4 settings of vpn connection you have checked "Use default gateway on remote network".

  • @szymonp said:
    Anyone know a solution?

    I don't think people know what you're trying to do and what you've done so far to actually bother.

  • @szymonp said:
    Anyone know a solution?

    you need to enable NAT. Last time I checked, in windows this was called ICS (Internet connection sharing). The people at microsuck change names every release and move things around so I don't know what it's called anymore or where it is.

  • emgemg Member

    @TimboJones said:
    I don't think people know what you're trying to do and what you've done so far to actually bother.

    Windows-based VPNs are not common. I doubt that you will find many people with Windows-based VPN experience.

    It might help us to understand why Windows and not Linux.

  • @emg said:

    @TimboJones said:
    I don't think people know what you're trying to do and what you've done so far to actually bother.

    Windows-based VPNs are not common. I doubt that you will find many people with Windows-based VPN experience.

    It might help us to understand why Windows and not Linux.

    They are in Enterprise. With a Windows Server version, it's pretty common. But if the guy can't provide more details, fuck 'em. He's not even helping himself.

    The most common reason is because it's built in to server and all Windows OS's. No additional client needed.

    Thanked by 1emg
  • aquaaqua Member, Patron Provider

    Use a OpenVPN based VPN. Should be all good and don't have to fiddle with network settings

  • @patro said:
    If client is windows make sure in ipv4 settings of vpn connection you have checked "Use default gateway on remote network".

    I don't have that option :/

  • But if the guy can't provide more details, fuck 'em. He's not even helping himself.

    Jeez sorry what details do you mean

  • mcsmcs Member

    @szymonp said:
    I tried setting up a VPN on my windows vps. At first it refused to even connect but I fixed that by manually entering the IP range and checking the "allow calling computer to specify it's own IP address" box.

    But now when it connects I don't have internet access. Suprisingly my RDP connection to the VPS doesn't close (all other RDP connections do...)
    I also noticed there is no connection on IPv4 even though I enabled it

    It is obvious that you are doing the following - Vpn Server on Windows 10 and missing the final steps from the instructions below. You shoud make Set up VPN connection on Windows 10, and the firewall is not configured to accept connections on special ports for full operation. Therefore, follow all the steps as in the instructions that I attach via the link and everything will work. Also check that your vps is not blocking connections on the specific ports you are configuring to accept connections.

    Manual - https://pureinfotech.com/setup-vpn-server-windows-10/

    Thanked by 1TimboJones
  • mcsmcs Member

    @patro said:
    If client is windows make sure in ipv4 settings of vpn connection you have checked "Use default gateway on remote network".

    Also, when setting up a vpn connection, check this moment, which you were advised to do correctly - make sure that in the settings of the ipv4 vpn connection you checked "Use the default gateway on the remote network". More details on the screenshots in the instructions - https://www3.uwsp.edu/infotech/Pages/Tutorials/VPN/Windows-10-VPN-Setup.aspx

  • emgemg Member

    @emg said:
    Windows-based VPNs are not common. I doubt that you will find many people with Windows-based VPN experience.

    It might help us to understand why Windows and not Linux.

    @TimboJones said:
    They are in Enterprise. With a Windows Server version, it's pretty common. But if the guy can't provide more details, fuck 'em. He's not even helping himself.

    The most common reason is because it's built in to server and all Windows OS's. No additional client needed.

    You are absolutely right. I was thinking of those VPN services for consumer internet privacy that are being heavily advertised. I assume that those VPN services are mostly Linux or Unix-based.

    For some reason, I had put out of mind those very common VPNs for remote access to work and similar business-related activities, which are often Windows-based.

    Yeah, and I did not mention point-to-point VPNs either. My bad.

Sign In or Register to comment.