Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Slow connection with my VPS
New on LowEndTalk? Please Register and read our Community Rules.

Slow connection with my VPS

There is an issue that is driving me crazy, it happens randomly and when I open a ticket they say that they cannot see any anomaly because they reply after hours when the problem is gone.
I have a Wireguard VPN on this VPS and everything is so slow when connected to it. These are some reports straight from the VPS:

PING 1.1.1.1 (1.1.1.1) 56(84) bytes of data.
64 bytes from 1.1.1.1: icmp_seq=1 ttl=58 time=39.5 ms
64 bytes from 1.1.1.1: icmp_seq=2 ttl=58 time=40.9 ms
64 bytes from 1.1.1.1: icmp_seq=3 ttl=58 time=52.5 ms
64 bytes from 1.1.1.1: icmp_seq=4 ttl=58 time=47.9 ms
64 bytes from 1.1.1.1: icmp_seq=5 ttl=58 time=44.6 ms
64 bytes from 1.1.1.1: icmp_seq=6 ttl=58 time=44.7 ms
64 bytes from 1.1.1.1: icmp_seq=7 ttl=58 time=49.8 ms
64 bytes from 1.1.1.1: icmp_seq=8 ttl=58 time=46.7 ms
64 bytes from 1.1.1.1: icmp_seq=9 ttl=58 time=57.6 ms
64 bytes from 1.1.1.1: icmp_seq=10 ttl=58 time=41.4 ms
64 bytes from 1.1.1.1: icmp_seq=11 ttl=58 time=41.3 ms
64 bytes from 1.1.1.1: icmp_seq=12 ttl=58 time=51.3 ms
64 bytes from 1.1.1.1: icmp_seq=13 ttl=58 time=49.3 ms
64 bytes from 1.1.1.1: icmp_seq=14 ttl=58 time=48.1 ms
64 bytes from 1.1.1.1: icmp_seq=15 ttl=58 time=46.1 ms
64 bytes from 1.1.1.1: icmp_seq=16 ttl=58 time=40.1 ms
64 bytes from 1.1.1.1: icmp_seq=17 ttl=58 time=54.2 ms
64 bytes from 1.1.1.1: icmp_seq=18 ttl=58 time=52.6 ms
64 bytes from 1.1.1.1: icmp_seq=19 ttl=58 time=43.9 ms
64 bytes from 1.1.1.1: icmp_seq=20 ttl=58 time=46.7 ms
64 bytes from 1.1.1.1: icmp_seq=21 ttl=58 time=39.8 ms
64 bytes from 1.1.1.1: icmp_seq=23 ttl=58 time=56.2 ms
64 bytes from 1.1.1.1: icmp_seq=24 ttl=58 time=49.2 ms
64 bytes from 1.1.1.1: icmp_seq=25 ttl=58 time=50.6 ms
64 bytes from 1.1.1.1: icmp_seq=26 ttl=58 time=47.5 ms
64 bytes from 1.1.1.1: icmp_seq=27 ttl=58 time=51.8 ms
64 bytes from 1.1.1.1: icmp_seq=28 ttl=58 time=49.4 ms
64 bytes from 1.1.1.1: icmp_seq=29 ttl=58 time=50.1 ms
64 bytes from 1.1.1.1: icmp_seq=30 ttl=58 time=30.4 ms
^C
--- 1.1.1.1 ping statistics ---
30 packets transmitted, 29 received, 3.33333% packet loss, time 29046ms
rtt min/avg/max/mdev = 30.371/47.038/57.616/5.737 ms
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=118 time=6.93 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=118 time=10.4 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=118 time=7.67 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=118 time=7.52 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=118 time=7.17 ms
64 bytes from 8.8.8.8: icmp_seq=6 ttl=118 time=8.05 ms
64 bytes from 8.8.8.8: icmp_seq=8 ttl=118 time=9.39 ms
64 bytes from 8.8.8.8: icmp_seq=9 ttl=118 time=6.66 ms
64 bytes from 8.8.8.8: icmp_seq=10 ttl=118 time=9.12 ms
64 bytes from 8.8.8.8: icmp_seq=11 ttl=118 time=5.86 ms
64 bytes from 8.8.8.8: icmp_seq=12 ttl=118 time=2.78 ms
64 bytes from 8.8.8.8: icmp_seq=13 ttl=118 time=5.85 ms
64 bytes from 8.8.8.8: icmp_seq=14 ttl=118 time=7.96 ms
64 bytes from 8.8.8.8: icmp_seq=15 ttl=118 time=5.56 ms
64 bytes from 8.8.8.8: icmp_seq=16 ttl=118 time=6.39 ms
64 bytes from 8.8.8.8: icmp_seq=17 ttl=118 time=7.69 ms
64 bytes from 8.8.8.8: icmp_seq=18 ttl=118 time=5.90 ms
64 bytes from 8.8.8.8: icmp_seq=19 ttl=118 time=7.25 ms
64 bytes from 8.8.8.8: icmp_seq=20 ttl=118 time=6.82 ms
64 bytes from 8.8.8.8: icmp_seq=21 ttl=118 time=5.91 ms
64 bytes from 8.8.8.8: icmp_seq=22 ttl=118 time=7.98 ms
64 bytes from 8.8.8.8: icmp_seq=23 ttl=118 time=10.0 ms
64 bytes from 8.8.8.8: icmp_seq=24 ttl=118 time=10.2 ms
64 bytes from 8.8.8.8: icmp_seq=25 ttl=118 time=9.17 ms
64 bytes from 8.8.8.8: icmp_seq=26 ttl=118 time=10.3 ms
64 bytes from 8.8.8.8: icmp_seq=27 ttl=118 time=8.49 ms
64 bytes from 8.8.8.8: icmp_seq=28 ttl=118 time=6.66 ms
64 bytes from 8.8.8.8: icmp_seq=29 ttl=118 time=3.05 ms
64 bytes from 8.8.8.8: icmp_seq=30 ttl=118 time=0.821 ms
^C
--- 8.8.8.8 ping statistics ---
30 packets transmitted, 29 received, 3.33333% packet loss, time 29062ms
rtt min/avg/max/mdev = 0.821/7.156/10.436/2.210 ms
traceroute to 1.1.1.1 (1.1.1.1), 64 hops max
  1   *  *  * 
  2   146.70.0.46  0.226ms  0.294ms  0.167ms 
  3   37.120.220.92  0.745ms  0.631ms  0.602ms 
  4   *  37.120.128.248  8.634ms  * 
  5   193.239.118.138  34.703ms  33.758ms  33.407ms 
  6   172.70.240.3  17.356ms  17.202ms  17.141ms 
  7   1.1.1.1  22.623ms  22.007ms  * 
traceroute to 8.8.8.8 (8.8.8.8), 64 hops max
  1   *  *  * 
  2   146.70.0.46  0.207ms  0.170ms  0.136ms 
  3   *  37.120.220.90  14.220ms  13.836ms 
  4   *  37.120.128.248  0.835ms  0.693ms 
  5   185.206.226.71  3.321ms  3.411ms  4.687ms 
  6   *  *  * 
  7   8.8.8.8  9.820ms  9.783ms  9.707ms 

In the past, when I opened the tickets ping to 8.8.8.8 was as high as about 300ms!

Do you see anything wrong here? Thank you very much for your help!

Comments

  • Can you post a MTR report with -c 30 instead? Preferably a report when you're experiencing issues and once when you're not. Also for me personally, most "noticeable" network lag usually has to do with DNS lookup or something with IPv6.

  • TheMisterTheMister Member
    edited November 13

    Thanks @black I'm currently experiencing issues.

    Here you go with the MTR report to 1.1.1.1:

    Start: 2022-11-13T19:56:24+0100
    HOST: antonio                          Loss%   Snt   Last   Avg  Best  Wrst StDev
      1.|-- 80.97.45.1                        0.0%    30   19.5  17.1   5.4  67.6  12.1
      2.|-- 146.70.0.48                       0.0%    30    0.3   0.3   0.2   0.5   0.1
      3.|-- 37.120.220.90                     6.7%    30   85.1  77.2  47.4  95.6  11.5
      4.|-- te-5-3-0.bb2.mad1.es.m247.com     0.0%    30   87.8  82.6  59.3  97.7   9.6
      5.|-- cloudflare.equinix-fr4.nl-ix.net  3.3%    30  100.0  94.4  76.3 109.7   9.3
      6.|-- 162.158.84.53                     0.0%    30   89.4  80.0  58.3 113.9  11.9
      7.|-- one.one.one.one                   3.3%    30  106.7  88.4  70.9 106.7   9.9
    

    And here a report to google.com

    Start: 2022-11-13T20:04:52+0100
    HOST: antonio                      Loss%   Snt   Last   Avg  Best  Wrst StDev
      1.|-- 2a0e:1d80:2::1                0.0%    30    0.3   0.4   0.3   0.7   0.1
      2.|-- 2a01:300b::217:138:210:138    0.0%    30    0.4   0.5   0.4   0.8   0.1
      3.|-- 2001:ac8:10:10:146:70:1:212  93.3%    30    0.8   0.9   0.8   0.9   0.0
      4.|-- 2001:ac8:10:10:212:103:51:63  0.0%    30    0.6   3.2   0.5  10.1   2.5
      5.|-- 2001:ac8:10:10::15d           0.0%    30    7.5   4.9   0.6   8.2   2.4
      6.|-- 2a00:1450:809c::1             6.7%    30    7.3   6.6   2.0  10.6   2.4
      7.|-- 2001:4860:0:1::310           66.7%    30   57.9  11.6   2.2  57.9  16.5
      8.|-- ???                          100.0    30    0.0   0.0   0.0   0.0   0.0
      9.|-- 2001:4860::c:4000:f874       60.0%    30    1.6   5.7   1.6   8.8   2.3
     10.|-- 2001:4860::c:4000:d9a9        0.0%    30    9.3  12.3   7.1  17.1   2.8
     11.|-- 2001:4860::9:4000:d476        0.0%    30    7.9  15.2   7.3  85.7  14.7
     12.|-- 2001:4860::12:0:a2d3         13.3%    30    9.0  16.5   8.1  52.0  12.4
     13.|-- 2001:4860:0:1::611d           0.0%    30    9.2   9.7   7.0  15.2   2.3
     14.|-- ams15s48-in-x0e.1e100.net     0.0%    30    9.5  10.1   7.1  15.6   2.2
    

    This VPS has IPv6 enabled. Might this be the issue?

  • blackblack Member
    edited November 13

    I'd try to turn off IPv6 and see what happens, preferably both on the PC connecting to the VPN server and the VPN server itself.

  • Nothing, I opened again the ticket with the provider, these are the results now

    PING 1.1.1.1 (1.1.1.1) 56(84) bytes of data.
    64 bytes from 1.1.1.1: icmp_seq=1 ttl=58 time=86.4 ms
    64 bytes from 1.1.1.1: icmp_seq=2 ttl=58 time=73.6 ms
    64 bytes from 1.1.1.1: icmp_seq=3 ttl=58 time=90.7 ms
    64 bytes from 1.1.1.1: icmp_seq=4 ttl=58 time=84.7 ms
    64 bytes from 1.1.1.1: icmp_seq=5 ttl=58 time=86.7 ms
    64 bytes from 1.1.1.1: icmp_seq=6 ttl=58 time=91.2 ms
    64 bytes from 1.1.1.1: icmp_seq=7 ttl=58 time=106 ms
    64 bytes from 1.1.1.1: icmp_seq=8 ttl=58 time=95.0 ms
    64 bytes from 1.1.1.1: icmp_seq=9 ttl=58 time=99.5 ms
    ^C
    --- 1.1.1.1 ping statistics ---
    9 packets transmitted, 9 received, 0% packet loss, time 8012ms
    rtt min/avg/max/mdev = 73.633/90.447/106.000/8.766 ms
    

    It seems that the ping is even higher than before.

  • This is just M247's network, unfortunately. Nothing they can do about it.

    Thanked by 1yoursunny
  • emgemg Member

    Could it be related to an excessive load caused by other VPSs that belong to abusive customers on the same physical server?

    Is the provider known for ultra low cost, overloaded, or oversold VPSs?

  • No idea, the provider is Virtono. They just replied me that the main server has no issues, well... my VPS in this moment is not affected either and I changed nothing.

    PING 1.1.1.1 (1.1.1.1) 56(84) bytes of data.
    64 bytes from 1.1.1.1: icmp_seq=1 ttl=58 time=9.38 ms
    64 bytes from 1.1.1.1: icmp_seq=2 ttl=58 time=8.42 ms
    64 bytes from 1.1.1.1: icmp_seq=3 ttl=58 time=8.55 ms
    64 bytes from 1.1.1.1: icmp_seq=4 ttl=58 time=10.7 ms
    64 bytes from 1.1.1.1: icmp_seq=5 ttl=58 time=5.02 ms
    64 bytes from 1.1.1.1: icmp_seq=6 ttl=58 time=4.89 ms
    64 bytes from 1.1.1.1: icmp_seq=7 ttl=58 time=7.50 ms
    64 bytes from 1.1.1.1: icmp_seq=8 ttl=58 time=4.63 ms
    64 bytes from 1.1.1.1: icmp_seq=9 ttl=58 time=7.63 ms
    64 bytes from 1.1.1.1: icmp_seq=10 ttl=58 time=8.61 ms
    64 bytes from 1.1.1.1: icmp_seq=11 ttl=58 time=7.94 ms
    64 bytes from 1.1.1.1: icmp_seq=12 ttl=58 time=8.49 ms
    64 bytes from 1.1.1.1: icmp_seq=13 ttl=58 time=4.69 ms
    64 bytes from 1.1.1.1: icmp_seq=14 ttl=58 time=3.79 ms
    64 bytes from 1.1.1.1: icmp_seq=15 ttl=58 time=11.2 ms
    64 bytes from 1.1.1.1: icmp_seq=16 ttl=58 time=4.15 ms
    64 bytes from 1.1.1.1: icmp_seq=17 ttl=58 time=9.67 ms
    64 bytes from 1.1.1.1: icmp_seq=18 ttl=58 time=7.14 ms
    64 bytes from 1.1.1.1: icmp_seq=19 ttl=58 time=7.22 ms
    64 bytes from 1.1.1.1: icmp_seq=20 ttl=58 time=5.38 ms
    64 bytes from 1.1.1.1: icmp_seq=21 ttl=58 time=9.82 ms
    64 bytes from 1.1.1.1: icmp_seq=22 ttl=58 time=11.1 ms
    64 bytes from 1.1.1.1: icmp_seq=23 ttl=58 time=8.58 ms
    64 bytes from 1.1.1.1: icmp_seq=24 ttl=58 time=3.87 ms
    64 bytes from 1.1.1.1: icmp_seq=25 ttl=58 time=13.5 ms
    64 bytes from 1.1.1.1: icmp_seq=26 ttl=58 time=8.41 ms
    64 bytes from 1.1.1.1: icmp_seq=27 ttl=58 time=7.58 ms
    64 bytes from 1.1.1.1: icmp_seq=28 ttl=58 time=7.50 ms
    64 bytes from 1.1.1.1: icmp_seq=29 ttl=58 time=4.44 ms
    64 bytes from 1.1.1.1: icmp_seq=30 ttl=58 time=2.67 ms
    ^C
    --- 1.1.1.1 ping statistics ---
    30 packets transmitted, 30 received, 0% packet loss, time 29049ms
    rtt min/avg/max/mdev = 2.666/7.416/13.542/2.567 ms
    
    Start: 2022-11-13T21:58:22+0100
    HOST: antonio                          Loss%   Snt   Last   Avg  Best  Wrst StDev
      1.|-- 80.97.45.1                        0.0%    30    9.6  21.8   4.6  74.4  18.0
      2.|-- 146.70.0.48                       0.0%    30    0.3   0.4   0.2   1.6   0.3
      3.|-- 37.120.220.90                     3.3%    30   12.7   7.9   0.6  19.5   6.1
      4.|-- te-5-3-0.bb2.mad1.es.m247.com     0.0%    30   22.9  11.2   3.6  22.9   5.9
      5.|-- cloudflare.equinix-fr4.nl-ix.net  0.0%    30   25.8  14.3   4.7  28.9   7.1
      6.|-- 162.158.84.53                    46.7%    30   26.2  12.8   1.7  45.3  10.8
      7.|-- one.one.one.one                   0.0%    30   26.7  12.1   1.9  26.7   5.0
    
  • hollowvi1hollowvi1 Member, Patron Provider

    @TheMister said:
    No idea, the provider is Virtono. They just replied me that the main server has no issues, well... my VPS in this moment is not affected either and I changed nothing.

    PING 1.1.1.1 (1.1.1.1) 56(84) bytes of data.
    64 bytes from 1.1.1.1: icmp_seq=1 ttl=58 time=9.38 ms
    64 bytes from 1.1.1.1: icmp_seq=2 ttl=58 time=8.42 ms
    64 bytes from 1.1.1.1: icmp_seq=3 ttl=58 time=8.55 ms
    64 bytes from 1.1.1.1: icmp_seq=4 ttl=58 time=10.7 ms
    64 bytes from 1.1.1.1: icmp_seq=5 ttl=58 time=5.02 ms
    64 bytes from 1.1.1.1: icmp_seq=6 ttl=58 time=4.89 ms
    64 bytes from 1.1.1.1: icmp_seq=7 ttl=58 time=7.50 ms
    64 bytes from 1.1.1.1: icmp_seq=8 ttl=58 time=4.63 ms
    64 bytes from 1.1.1.1: icmp_seq=9 ttl=58 time=7.63 ms
    64 bytes from 1.1.1.1: icmp_seq=10 ttl=58 time=8.61 ms
    64 bytes from 1.1.1.1: icmp_seq=11 ttl=58 time=7.94 ms
    64 bytes from 1.1.1.1: icmp_seq=12 ttl=58 time=8.49 ms
    64 bytes from 1.1.1.1: icmp_seq=13 ttl=58 time=4.69 ms
    64 bytes from 1.1.1.1: icmp_seq=14 ttl=58 time=3.79 ms
    64 bytes from 1.1.1.1: icmp_seq=15 ttl=58 time=11.2 ms
    64 bytes from 1.1.1.1: icmp_seq=16 ttl=58 time=4.15 ms
    64 bytes from 1.1.1.1: icmp_seq=17 ttl=58 time=9.67 ms
    64 bytes from 1.1.1.1: icmp_seq=18 ttl=58 time=7.14 ms
    64 bytes from 1.1.1.1: icmp_seq=19 ttl=58 time=7.22 ms
    64 bytes from 1.1.1.1: icmp_seq=20 ttl=58 time=5.38 ms
    64 bytes from 1.1.1.1: icmp_seq=21 ttl=58 time=9.82 ms
    64 bytes from 1.1.1.1: icmp_seq=22 ttl=58 time=11.1 ms
    64 bytes from 1.1.1.1: icmp_seq=23 ttl=58 time=8.58 ms
    64 bytes from 1.1.1.1: icmp_seq=24 ttl=58 time=3.87 ms
    64 bytes from 1.1.1.1: icmp_seq=25 ttl=58 time=13.5 ms
    64 bytes from 1.1.1.1: icmp_seq=26 ttl=58 time=8.41 ms
    64 bytes from 1.1.1.1: icmp_seq=27 ttl=58 time=7.58 ms
    64 bytes from 1.1.1.1: icmp_seq=28 ttl=58 time=7.50 ms
    64 bytes from 1.1.1.1: icmp_seq=29 ttl=58 time=4.44 ms
    64 bytes from 1.1.1.1: icmp_seq=30 ttl=58 time=2.67 ms
    ^C
    --- 1.1.1.1 ping statistics ---
    30 packets transmitted, 30 received, 0% packet loss, time 29049ms
    rtt min/avg/max/mdev = 2.666/7.416/13.542/2.567 ms
    
    Start: 2022-11-13T21:58:22+0100
    HOST: antonio                          Loss%   Snt   Last   Avg  Best  Wrst StDev
      1.|-- 80.97.45.1                        0.0%    30    9.6  21.8   4.6  74.4  18.0
      2.|-- 146.70.0.48                       0.0%    30    0.3   0.4   0.2   1.6   0.3
      3.|-- 37.120.220.90                     3.3%    30   12.7   7.9   0.6  19.5   6.1
      4.|-- te-5-3-0.bb2.mad1.es.m247.com     0.0%    30   22.9  11.2   3.6  22.9   5.9
      5.|-- cloudflare.equinix-fr4.nl-ix.net  0.0%    30   25.8  14.3   4.7  28.9   7.1
      6.|-- 162.158.84.53                    46.7%    30   26.2  12.8   1.7  45.3  10.8
      7.|-- one.one.one.one                   0.0%    30   26.7  12.1   1.9  26.7   5.0
    

    It's definitely an issue with whatever their using to keep your VPS Connected. But it may have not been in their control. It may have been something behind the scenes.

Sign In or Register to comment.