Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


After copying files from cpanel backup file to virtualmin server manually, it gave HTTP500
New on LowEndTalk? Please Register and read our Community Rules.

After copying files from cpanel backup file to virtualmin server manually, it gave HTTP500

LikloveLiklove Member
edited September 28 in Help

The migrate server function on virtualmin doesnt work. Because when trying to migrate cpanel backup into it then it gives mail aliases errors.
So i have to manually copy the public html / folder from cpanel backup to virtual server.

After extracting files from cpanel backup file to virtualmin server manually, the website gives HTTP 500/blank page

I know there are numerous things that would cause white screen on wordpress after migration. But i tried all of them but none of them works even wp debug still gives white screen.

I tried these things and still white screen everywhere of the site:

  • Deleting htaccess and using default htaccess
  • Modifying htaccess
  • wp debug on
  • removing white spaces from wp-config file
  • renaming both plugins and themes directory
  • renaming wordfence files
  • changing php versions from 7.4 to 7.3 and vice versa
  • restoring database from mysql file to mariadb

I am surprised that when wpdebug enabled and it still gives white screen and no errors showing.

Only apache error logs i can get:

    [Sun Sep 26  2021] [fcgid:warn] [pid 14093] [client ] mod_fcgid: stderr: PHP Fatal error:  Unknown: Failed opening required '/home/...../public_html/wordfence-waf.php' (include_path='.:/opt/rh/rh-php73/root/usr/share/pear:/opt/rh/rh-php73/root/usr/share/php') in Unknown on line 0
[Sun Sep 26  2021] [negotiation:error] [pid 1491] [client ] AH00687: Negotiation: discovered file(s) matching request: /home/........./public_html/index.html 

Here is the latest apache error logs:

[Mon Sep 27  2021] [negotiation:error] [pid 16610] [client ] AH00687: Negotiation: discovered file(s) matching request: /home/mysite/public_html/index.html (None could be negotiated)., referer: https://www.mysite.com/
[Mon Sep 27  2021] [cgi:error] [pid 16610] [client ] AH01215: PHP Warning:  Unknown: failed to open stream: No such file or directory in Unknown on line 0, referer: https://www.mysite.com/
[Mon Sep 27  2021] [cgi:error] [pid 16610] [client] AH01215: PHP Fatal error:  Unknown: Failed opening required '/home/mysite2/public_html/wordfence-waf.php' (include_path='.:/usr/share/pear:/usr/share/php') in Unknown on line 0, referer: https://www.mysite.com/

I am sure this is not wordfence related issue because tried to remove all wordfence related file/folders/database tables etc. and still gives blank page.

How to fix?

Comments

  • 8-ball says: get a sysadmin.

    fix your owners/permissions and paths

    Thanked by 1WebProject

    UltraVPS.eu KVM in US/UK/NL/DE: 15% off first 6 month | Netcup VPS/rootDS - 5€ off: 36nc15279180197 (ref)

  • @Falzo said:
    8-ball says: get a sysadmin.

    fix your owners/permissions and paths

    cannot afford it. the cheapest wants 100 usd/p hour.

  • deankdeank Member, Troll

    Oh, my. That's not the way to do it.

    Get a sysadmin.

    If you wish to join Nigh sect, adopt my avatar as your own and believe in the end.

  • if it's just wordpress and you don't have enough experience with migrating on the command line rather use something like duplicator or such, which build you a complete installation/migration package that runs of a php-script.

    other than that, as said above, check paths and fix owners/permissions which probably are off.

    UltraVPS.eu KVM in US/UK/NL/DE: 15% off first 6 month | Netcup VPS/rootDS - 5€ off: 36nc15279180197 (ref)

  • WebProjectWebProject Member, Provider

    @Liklove said:

    @Falzo said:
    8-ball says: get a sysadmin.

    fix your owners/permissions and paths

    cannot afford it. the cheapest wants 100 usd/p hour.

    We can do better rate than $100 for fixing the issue.

    If you need help contact us.

    VPS Price Match Guarantee on: All our range of DDOS protected VPS Plans
    Are you looking for best price for self-managed VPS? See WebProVPS website for more details.
  • @Liklove said:

        [Sun Sep 26  2021] [fcgid:warn] [pid 14093] [client ] mod_fcgid: stderr: PHP Fatal error:  Unknown: Failed opening required '/home/...../public_html/wordfence-waf.php' (include_path='.:/opt/rh/rh-php73/root/usr/share/pear:/opt/rh/rh-php73/root/usr/share/php') in Unknown on line 0
    [Sun Sep 26  2021] [negotiation:error] [pid 1491] [client ] AH00687: Negotiation: discovered file(s) matching request: /home/........./public_html/index.html 
    

    Here is the latest apache error logs:

    [Mon Sep 27  2021] [negotiation:error] [pid 16610] [client ] AH00687: Negotiation: discovered file(s) matching request: /home/mysite/public_html/index.html (None could be negotiated)., referer: https://www.mysite.com/
    [Mon Sep 27  2021] [cgi:error] [pid 16610] [client ] AH01215: PHP Warning:  Unknown: failed to open stream: No such file or directory in Unknown on line 0, referer: https://www.mysite.com/
    [Mon Sep 27  2021] [cgi:error] [pid 16610] [client] AH01215: PHP Fatal error:  Unknown: Failed opening required '/home/mysite2/public_html/wordfence-waf.(include_path='.:/usr/share/pear:/usr/share/php') in Unknown on line 0, referer: https://www.mysite.com/
    

    Are you sure that's the correct include_path?

  • lentrolentro Member, Provider

    You don't have an index.html file, right?

  • PHP Fatal error: Unknown: Failed opening required '/home/mysite2/public_html/wordfence-waf.php'

    the general rule of thumb, while migrating WordPress disable any security plugins

    If you want access to a system all you have to do is ask - Kevin Mitnick

  • jetchiragjetchirag Member
    edited September 29

    In your htaccess and/or user.ini and/or wp-config.php file, there would be a line to include wordpress-waf.php where path is hardcoded. Just remove it.

    If you don't find it any of these files, search for it: grep -r "public_html/wordfence-waf.php" . after changing to your public root.

  • LikloveLiklove Member
    edited September 29

    @asaljeplak said:

    @Liklove said:

        [Sun Sep 26  2021] [fcgid:warn] [pid 14093] [client ] mod_fcgid: stderr: PHP Fatal error:  Unknown: Failed opening required '/home/...../public_html/wordfence-waf.php' (include_path='.:/opt/rh/rh-php73/root/usr/share/pear:/opt/rh/rh-php73/root/usr/share/php') in Unknown on line 0
    [Sun Sep 26  2021] [negotiation:error] [pid 1491] [client ] AH00687: Negotiation: discovered file(s) matching request: /home/........./public_html/index.html 
    

    Here is the latest apache error logs:

    [Mon Sep 27  2021] [negotiation:error] [pid 16610] [client ] AH00687: Negotiation: discovered file(s) matching request: /home/mysite/public_html/index.html (None could be negotiated)., referer: https://www.mysite.com/
    [Mon Sep 27  2021] [cgi:error] [pid 16610] [client ] AH01215: PHP Warning:  Unknown: failed to open stream: No such file or directory in Unknown on line 0, referer: https://www.mysite.com/
    [Mon Sep 27  2021] [cgi:error] [pid 16610] [client] AH01215: PHP Fatal error:  Unknown: Failed opening required '/home/mysite2/public_html/wordfence-waf.(include_path='.:/usr/share/pear:/usr/share/php') in Unknown on line 0, referer: https://www.mysite.com/
    

    Are you sure that's the correct include_path?

    The top level directory name was different on previous cpanel, when i rename to that it give 403 forbidden error

    @lentro said:
    You don't have an index.html file, right?

    Ive had that and removed bcz it was just showing virtualmin example page.

    @jetchirag said:
    In your htaccess and/or user.ini and/or wp-config.php file, there would be a line to include wordpress-waf.php where path is hardcoded. Just remove it.

    If you don't find it any of these files, search for it: grep -r "public_html/wordfence-waf.php" . after changing to your public root.

    Yeah ive had removed and tried but still getting http500/blank page.

    There is no access to phpmyadmin (http500) too so i also cannot import full database, just imported some into mariadb.bcz wp posts tables gives doesnt exist errors.

    Can you instruct step by step for doing restoration of cpanel jetbackup into virtualmin manually? Bcz there isnt any good tutorial on the web.

    Note:
    Here is What i did :

    • extracted tar gz into the server somewhere
    • created new virtual server on virtualmin
    • Copied and overwrote public_html folder from backup to new virtual server
    • And it gave http500 as said above
    • also executed sql database into mariadb

    Note2: the auto restoration wont work bcz it gives mail aliases error for cpanel backup

    So do u know a better way?

  • @Liklove have you updated new database config in wp-config file? And if you can't import database then ofc wordpress won't work. You can import via ssh.

    mysql -u user -p database < dump.sql
    
  • @jetchirag said:
    @Liklove have you updated new database config in wp-config file? And if you can't import database then ofc wordpress won't work. You can import via ssh.

    mysql -u user -p database < dump.sql
    

    Yes already updated the wp config but it is obvious there is a server related issue besides wp.
    So first i have to fix the server issue before database.

    Note: actually most of the mysql database tables are importing succesfully but some of them are not such as wp_posts etc.

  • RHCHostingRHCHosting Member, Provider

    Looks like a permission issue to me. Have you given the files/folders the correct owner/permissions? Also : wordfence-waf.php cannot be found. Make sure the path is correct.

  • @RHCHosting said:
    Looks like a permission issue to me. Have you given the files/folders the correct owner/permissions? Also : wordfence-waf.php cannot be found. Make sure the path is correct.

    Yeah tried that. Still 403 forbidden issue if the toplevel directory renamed. Otherwise http500

  • mywebhostingmywebhosting Member, Provider

    @Liklove said:
    The migrate server function on virtualmin doesnt work. Because when trying to migrate cpanel backup into it then it gives mail aliases errors.
    So i have to manually copy the public html / folder from cpanel backup to virtual server.

    After extracting files from cpanel backup file to virtualmin server manually, the website gives HTTP 500/blank page

    I know there are numerous things that would cause white screen on wordpress after migration. But i tried all of them but none of them works even wp debug still gives white screen.

    I tried these things and still white screen everywhere of the site:

    • Deleting htaccess and using default htaccess
    • Modifying htaccess
    • wp debug on
    • removing white spaces from wp-config file
    • renaming both plugins and themes directory
    • renaming wordfence files
    • changing php versions from 7.4 to 7.3 and vice versa
    • restoring database from mysql file to mariadb

    I am surprised that when wpdebug enabled and it still gives white screen and no errors showing.

    Only apache error logs i can get:

        [Sun Sep 26  2021] [fcgid:warn] [pid 14093] [client ] mod_fcgid: stderr: PHP Fatal error:  Unknown: Failed opening required '/home/...../public_html/wordfence-waf.php' (include_path='.:/opt/rh/rh-php73/root/usr/share/pear:/opt/rh/rh-php73/root/usr/share/php') in Unknown on line 0
    [Sun Sep 26  2021] [negotiation:error] [pid 1491] [client ] AH00687: Negotiation: discovered file(s) matching request: /home/........./public_html/index.html 
    

    Here is the latest apache error logs:

    [Mon Sep 27  2021] [negotiation:error] [pid 16610] [client ] AH00687: Negotiation: discovered file(s) matching request: /home/mysite/public_html/index.html (None could be negotiated)., referer: https://www.mysite.com/
    [Mon Sep 27  2021] [cgi:error] [pid 16610] [client ] AH01215: PHP Warning:  Unknown: failed to open stream: No such file or directory in Unknown on line 0, referer: https://www.mysite.com/
    [Mon Sep 27  2021] [cgi:error] [pid 16610] [client] AH01215: PHP Fatal error:  Unknown: Failed opening required '/home/mysite2/public_html/wordfence-waf.php' (include_path='.:/usr/share/pear:/usr/share/php') in Unknown on line 0, referer: https://www.mysite.com/
    

    I am sure this is not wordfence related issue because tried to remove all wordfence related file/folders/database tables etc. and still gives blank page.

    How to fix?

    Are the MySQL and PHP version same for both the servers?

  • @mywebhosting said:

    Are the MySQL and PHP version same for both the servers?

    Php would be different but Tried 7.3,7.4 and 7.1 but nothing changed.
    For mysql in virtualmin it has mariadb installed -also mysql- however i cant even access to phpmyadmin page

Sign In or Register to comment.