Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


The service 'httpd' on server *** is currently down
New on LowEndTalk? Please Register and read our Community Rules.

The service 'httpd' on server *** is currently down

I am getting this issue after CloudLinux & LiteSpeed Installation

On httpd restart : Failed to restart httpd.service: Unit not found.

I tried yum install httpd i got error : No package httpd available.

Kindly let me know how to solve it.

Comments

  • ezethezeth Member, Provider

    Try a yum update

  • @ezeth said:
    Try a yum update

    Already tried.

  • Did you try a quick cat /dev/sda to inspect datagrams?

  • deankdeank Member, Troll

    Turn it off and remain it offline.

    Issue solved, in a twisted way.

    Thanked by 1WebProject

    If you wish to join Nigh sect, adopt my avatar as your own and believe in the end.

  • @deank said:
    Turn it off and remain it offline.

    Issue solved, in a twisted way.

    Lol, will there be any issue if it shall kept offline?

  • @deank said:
    Turn it off and remain it offline.

    Issue solved, in a twisted way.

    Excuse me, but you're being silly
    Reboot it for 35 hours,it'll be fine after the 38th.

  • deankdeank Member, Troll

    @DataBuster said:
    Lol, will there be any issue if it shall kept offline?

    See? That's the gist. Keep it offline, and you won't have issues.

    If you wish to join Nigh sect, adopt my avatar as your own and believe in the end.

  • Its selective uptime, and this is true beauty.

  • TheLinuxBugTheLinuxBug Member
    edited September 28

    If you are paying for a CloudLinux license contact their support directly and ask for assistance. They are quite responsive and will be better able to answer your questions and concerns than the trolls here on LET. One thing that is good about having a license with them is they actually have decent support with their software, so, take advantage of it and ask them for help and they should be able to get you squared away.

    my 2 cents.

    Cheers!

    Thanked by 1yoursunny

    Have an Allwinner H3 device? Check out H3Droid! | Lichee Pi Zero - The 6$ SBC | #SYSarm - Get It! | Armbian | Atomic Pi Mirror
    22+ Years IT Experience in Linux/Windows Hosting, Administration and Development Services

  • verovero Member, Provider

    @DataBuster said:
    I am getting this issue after CloudLinux & LiteSpeed Installation

    On httpd restart : Failed to restart httpd.service: Unit not found.

    Either you're running LiteSpeed or Apache. Or you expect both?

    Thanked by 1Falzo
  • @vero said:

    @DataBuster said:
    I am getting this issue after CloudLinux & LiteSpeed Installation

    On httpd restart : Failed to restart httpd.service: Unit not found.

    Either you're running LiteSpeed or Apache. Or you expect both?

    currently using openlitespeed. My litespeed license is for pending 1 year update. thought trying the openlitespeed

  • Point is.. by installing LiteSpeed (or open) it probably removed httpd (Apache). You can't run 2 services on same port

    I can do: Gentoo & Debian with security and performance in mind

  • RadiRadi Member, Provider

    Try "service lsws restart".

    4 GB RAM/90 GB SSD/4 TB Traffic/KVM/1 IPv4 for $7/mo only here with coupon code "LET-It-GO".

  • systemctl list-unit-files
    Find your openlitespeed service and start/enable it

  • WebProjectWebProject Member, Provider

    LiteSpeed Is not Apache so cannot be httpd.

    We can offer server management services, if required?

    VPS Price Match Guarantee on: All our range of DDOS protected VPS Plans
    Are you looking for best price for self-managed VPS? See WebProVPS website for more details.
  • @amarc said:
    Point is.. by installing LiteSpeed (or open) it probably removed httpd (Apache). You can't run 2 services on same port

    How can i stop there message from directadmin, I probably removed apache from everywhere already. But it is annoying getting the same error again & again every few minutes.

  • @WebProject said:
    LiteSpeed Is not Apache so cannot be httpd.

    We can offer server management services, if required?

    I just currently need to remove that annoying message from directadmin.

  • DA, i take it? Could you post the output of:

    journalctl -xe -u lshttpd

    And

    ps auxf | grep ls

  • @FoxelVox said:
    DA, i take it? Could you post the output of:

    journalctl -xe -u lshttpd

    And

    ps auxf | grep ls

    libstor+ 1052 0.0 0.0 8596 1800 ? Ss Sep26 0:00 /usr/bin/lsmd -d
    root 16251 0.0 0.0 112828 2200 pts/0 S+ 21:41 0:00 _ grep --color=auto ls
    root 31077 0.0 0.0 85444 30168 ? S 00:11 0:09 openlitespeed (lshttpd - main)
    root 31078 0.0 0.0 39624 3576 ? S 00:11 0:02 _ openlitespeed (lscgid)
    apache 31080 0.0 0.0 91328 29552 ? S 00:11 0:33 _ openlitespeed (lshttpd - #01)
    apache 31081 0.0 0.0 87076 28936 ? S 00:11 0:31 _ openlitespeed (lshttpd - #02)

  • @FoxelVox said:
    DA, i take it? Could you post the output of:

    journalctl -xe -u lshttpd

    And

    ps auxf | grep ls

    journalctl -xe -u lshttpd
    No Entries

  • Okay OLS no enterprise LS, did you try a

    cd /usr/local/directadmin/custombuild
    ./build rewrite_confs

    yet?

  • systemctl disable httpd.service
    rm /etc/systemd/system/multi-user.target.wants/httpd.service

  • @FoxelVox said:
    Okay OLS no enterprise LS, did you try a

    cd /usr/local/directadmin/custombuild
    ./build rewrite_confs

    yet?

    Nope, just tried now.

  • @tetech said:
    systemctl disable httpd.service
    rm /etc/systemd/system/multi-user.target.wants/httpd.service

    This will not cause to any of the running website right ?

  • @DataBuster said:

    @FoxelVox said:
    Okay OLS no enterprise LS, did you try a

    cd /usr/local/directadmin/custombuild
    ./build rewrite_confs

    yet?

    Nope, just tried now.

    Let me know if it helps!

    @DataBuster said:

    @tetech said:
    systemctl disable httpd.service
    rm /etc/systemd/system/multi-user.target.wants/httpd.service

    This will not cause to any of the running website right ?

    By deleting the service you’ll get other errors like the service file cannot be accessed or does not exist. Ill dive into it later tonight if it still isnt fixed where you can disable that service monitoring

  • @FoxelVox said:

    @DataBuster said:

    @FoxelVox said:
    Okay OLS no enterprise LS, did you try a

    cd /usr/local/directadmin/custombuild
    ./build rewrite_confs

    yet?

    Nope, just tried now.

    Let me know if it helps!

    @DataBuster said:

    @tetech said:
    systemctl disable httpd.service
    rm /etc/systemd/system/multi-user.target.wants/httpd.service

    This will not cause to any of the running website right ?

    By deleting the service you’ll get other errors like the service file cannot be accessed or does not exist. Ill dive into it later tonight if it still isnt fixed where you can disable that service monitoring

    The issue still not solved. Please let me know the solution

  • Okay let's just kill apache and its service monitoring if any remains are perhaps leftover from the custombuild compile;

    Execute these commands:

    systemctl disable --now httpd
    perl -pi -e 's/httpd=ON/httpd=OFF/' /usr/local/directadmin/data/admin/services.status
    systemctl restart directadmin
    
  • tetechtetech Member
    edited September 29

    @DataBuster said:

    @tetech said:
    systemctl disable httpd.service
    rm /etc/systemd/system/multi-user.target.wants/httpd.service

    This will not cause to any of the running website right ?

    Not if you're running lsws. The point is there's probably a dead systemd symlink pointing somewhere that doesn't exist any more. ls -l /etc/systemd/system/multi-user.target.wants/httpd.service ; ls -l /usr/lib/systemd/system/httpd.service. The systemctl disable httpd.service should just remove the dead symlink.

    @FoxelVox said: perl -pi -e 's/httpd=ON/httpd=OFF/' /usr/local/directadmin/data/admin/services.status systemctl restart directadmin

    Probably useful.

Sign In or Register to comment.