Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

DNS Confusion
New on LowEndTalk? Please Register and read our Community Rules.

DNS Confusion

donblancodonblanco Member

I'm used to just changing nameservers when I move sites around, but doing my own VPS seems to have complicated that. So I have tried establishing my own nameservers and it looked like they were propagating properly, but now seem to be actually propagating back to ... ? Not sure where actually. Not to my VPS, unfortunately.

So two questions:

1 - is there an easier way of pointing my domains to the new VPS without setting up nameservers and DNS Zone, etc?
2 - If not, is there a good tutorial out there somewhere? The ones I found were unclear and/or didn't match the options available at Uniregistry (my registrar).

Thanks in advance...


    1. Use 3rd party name server. You can use your domain provider nameserver or other 3rd party like cloudflare etc.. just point your A record and other record that you need to your vps IP address.

    2. If you want to use something like ns1.xxxx.yyy for domain xxxx.yyy then you will need to add/edit glue record. Ask your domain provider if it is possible, some provider allow you to add/edit from their panel ( example namecheap : ) or you need to create a ticket.
      If you already have your own name server ns1.xxxx.yyy and want to use that for then just change name server configuration on your domain provider. Don't forget to create all necessary record on your nameserver.

    Thanked by 2donblanco dedicados
  • JanevskiJanevski Member
    edited May 2019

    Use cloudflare, but disable record protection.
    Click on the A record entry cloud / around the cloud image.

    Or use a register which provides small DNS panel for the domain.

    Or use Hurricane Electric free dns...

    Or just google how to configure bind...

  • GravelyGravely Member

    My favourite combo;

    1. - use free or purchase a DNS package. Add a master zone, see your nameservers to the NS records indicated at ClouDNS within the master zone.

    2. Create an A record within your Master Zone pointing to your VPS IP

    3. Configure the webserver side. Done

  • Current setup:

    In my registrar:

    Under 'advanced' I have both ns1 and set up as nameservers pointing to VPS IP address
    The domain name is set to use ns1 and as nameservers

    At VPS:

    I have both ns1 and ns2 pointed to IP set up under A records in the DNS Zone

    So far the global dns propagation is updated for 13 out of 17 for ns1 and 11 out of 17 for ns2. However, the response for the domain name itself (with no subdomain in front) is absolutely zero.

    so I'm still doing something wrong. :\

  • poissonpoisson Member
    edited May 2019

    I am no expert, but sounds like a problem with your zone file or DNS bind on your VPS. There should be enough tutorials online for you to check out for troubleshooting to see if these are indeed the issues.

  • Found an example indicating two sets of dns zone entries in Cyberpanel

    1- A record for ns1 and 2 > IP address
    2- NS record for domain > ns1 and 2

    Ns1 and 2 now almost fully propagated. Domain itself, still nada :(

  • PHDanPHDan Member

    dig the domains against a public DNS server like and see the response.
    dig the domains against ns1 and ns2 (are they the same IP?) and see the response.

  • donblancodonblanco Member
    edited May 2019

    Not sure if the SOA is right - it was added automatically, but one domain name seems off:

    `ID Type Name TTL Value Priority

    14 SOA 3600 1 10800 3600 604800 3600 0`

    So would the 'hostmaster' part cause an issue? [NVM - hostmaster is default value in all DNS SOA records]

  • trewqtrewq Administrator, Patron Provider

    This is going to sound silly but do you have an A record on the root of the domain?

  • donblancodonblanco Member
    edited May 2019

    @trewq said:
    This is going to sound silly but do you have an A record on the root of the domain?

    At my registrar it just points to my nameservers

    At my new VPS I have both a and cname set up. The cname has propagated, the a record has not.

    I'm stumped

  • Adam1Adam1 Member
    edited May 2019

    ;yourdomain IN A
    yourdomain. 292 IN CNAME

    you dont have a (valid) A record, and you have a CNAME pointing to an IP, not a hostname

    fix zone file, restart whatever dns service you're using

    Thanked by 1donblanco
  • donblancodonblanco Member
    edited May 2019

    EDIT: Even though I am pretty sure I had done this before, I think it was conflicting with the CNAME - I re-added the A record at my VPS DNS panel, and it immediately started propagating. So that really should fix the last piece, I think...

    I removed the CNAME on my VPS.

    So in my registrar I have created custom nameservers which point to my VPS IP, and I have assigned those nameservers to my domain. In order to create a separate A record at my registrar I would have to remove the nameservers, which rather defeats the purpose it seems.

  • Adam1Adam1 Member

    i've edited out your domain from my post, in case you want to remove it from google etc

    Thanked by 1donblanco
  • I was in same situation and then i followed this tutorial. I literally copied everything and replaced ip and domain and it worked. You may try this tutorial.

    Thanked by 1donblanco
Sign In or Register to comment.