Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


In this Discussion

New on LowEndTalk? Please Register and read our Community Rules.

All new Registrations are manually reviewed and approved, so a short delay after registration may occur before your account becomes active.

Proxmox-5 Can not create new VM or CT

DrMakDrMak Member

I have installed proxmox 5.0 on OVH server and everything was fine except Whenever i try to create a VM or CT I got an error:

Using default stripesize 64.00 KiB. TASK ERROR: lvcreate 'pve/vm-100-disk-1' error: Logical volume pve/data is not a thin pool.

More Details:

vgs

VG #PV #LV #SN Attr VSize VFree
pve 1 5 0 wz--n- 398.15g 3.61g

pvs

PV VG Fmt Attr PSize PFree
/dev/md4 pve lvm2 a-- 398.15g 3.61g

Storage.cfg
dir: local
path /var/lib/vz
content vztmpl,backup,iso

lvmthin: local-lvm
vgname pve
thinpool data
content rootdir,images

lvs

LV VG Attr LSize Pool Origin Data% Meta% Move Log Cpy%Sync Convert
data pve -wi-ao---- 394.15g
lvol0 pve -wi-a----- 100.00m
lvol1 pve -wi-a----- 100.00m
lvol2 pve -wi------- 100.00m
lvol3 pve -wi------- 100.00m

pveversion -v

proxmox-ve: 5.0-15 (running kernel: 4.10.15-1-pve)
pve-manager: 5.0-23 (running version: 5.0-23/af4267bf)
pve-kernel-4.10.15-1-pve: 4.10.15-15
libpve-http-server-perl: 2.0-5
lvm2: 2.02.168-pve2
corosync: 2.4.2-pve3
libqb0: 1.0.1-1
pve-cluster: 5.0-10
qemu-server: 5.0-12
pve-firmware: 2.0-2
libpve-common-perl: 5.0-16
libpve-guest-common-perl: 2.0-11
libpve-access-control: 5.0-5
libpve-storage-perl: 5.0-12
pve-libspice-server1: 0.12.8-3
vncterm: 1.5-2
pve-docs: 5.0-8
pve-qemu-kvm: 2.9.0-2
pve-container: 2.0-14
pve-firewall: 3.0-1
pve-ha-manager: 2.0-2
ksm-control-daemon: not correctly installed
glusterfs-client: 3.8.8-1
lxc-pve: 2.0.8-3
lxcfs: 2.0.7-pve2
criu: 2.11.1-1~bpo90
novnc-pve: 0.6-4
smartmontools: 6.5+svn4324-1
zfsutils-linux: 0.6.5.9-pve16~bpo90

Comments

  • ehabehab Veteran

    this may not be the best solution for you but i had to delete all partions before new install.

  • RayhanRayhan Member

    Go to Datacenter > Storage and edit local drive. Then, make the local disk as shared by tick on option Shared: ✔ and select all as content storage like the screenshot.

    I believe that, your problems will be solved.

    Thanked by 1netomx
Sign In or Register to comment.