Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with OpenID
Advertise on LowEndTalk.com

In this Discussion

Userdir and su_php in apache

Userdir and su_php in apache

exussumexussum Member
edited August 2012 in General

Using userdir when accessing by ip/~username it uses a default account rather than the user specified name from the URL

Im not sure where to add the config to allow this to work ? It works fine with mod_php (and www owned scripts) Any suggestions ?

it works fine though the main domain, Just the /~username im having issues with

Comments

  • Try editing suphp.conf, and setting check_vhost_docroot to false.

    I am no longer affiliated with IPXcore.
  • BTW, mod_ruid2 performs better than su_php and also works for other Apache-launched dynamic content, including SSIs, CGIs, etc. Might be worth considering.

  • I've installed ruid2. Same issue ill see whati can find in the config for it

  • MrDOSMrDOS Member
    edited August 2012

    You've got to set RMode to, IIRC, stat (as opposed to config). That will cause it to run Apache as the user who owns the requested file. (Given that, make sure you have RMinUidGid set properly and don't leave anything chowned as the wrong user in someone's home directory.)

  • ive run

    chown -R user:user .

    in the user folder. and changing to stat worked.

    Now ive got an issue which which basedir doesnt seem to work in the ~/user url, But i may disable it as as long as everything is 660 it cant be changed anyway

    Thanks for the help ! Much appreciated

  • exussumexussum Member
    edited August 2012

    Solved it was using

     < Location />
    php_admin_value open_basedir
    < /Location
    

    instead of

    < Directory "/home/user/www">
    php_admin_value open_basedir
    < /Directory>
    

    Thanks !

    added spaces to show properly

Sign In or Register to comment.