Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with OpenID
Advertise on LowEndTalk.com

In this Discussion

Installing Php 5.1 on CentOS 6

Installing Php 5.1 on CentOS 6

globerglober Member
edited December 2011 in Help

By default yum installs php5.3 on CentOS 6.

Is there a way to get php 5.1 installed on this distributation?

Tagged:

Comments

  • Not in a position to test this but some google'ing pulls this up:

    http://www.zulius.com/how-to/yum-install-specific-package-version/

    Does that help?

  • @glober said: Is there a way to get php 5.1 installed on this distributation?

    Yes, there are a way. 1. Download source from php.net 2. Configure it 3. Compile 4. Install

  • @tux said: Yes, there are a way. 1. Download source from php.net 2. Configure it 3. Compile 4. Install

    And you'll have an out-of-date, unmaintained and vulnerable PHP environment. All you need then is a two-year-old copy of Wordpress :)

  • SpeedBusSpeedBus Member
    edited December 2011

    Give this a try, should work, http://www.webtatic.com/packages/php53/

    It should get you the latest version which exists in their repo, not sure if you'll get php version 5.3 as i'm sure it must have been updated since that blog post was made on that site.

    Edit : Why PHP version 5.1 ? That's so old !

    OpenVZ | Los Angeles, California | 8 Cores CPU | 3 GB RAM | 50 GB Disk | 3 TB bandwidth/month | $30/Year | Here !
  • @sleddog said: two-year-old copy of Wordpress

    All you need is to be 1 revision out for hell to surface, php compiled from source is fine, the sky is not falling.

    But quick google search http://blog.famillecollet.com/pages/Config-en shows adding REMI repo will provide php 5.3 rpm's

    Hostigation High Resource Hosting - SolusVM OpenVZ/KVM VPS
  • @SpeedBus said: Give this a try, should work, http://www.webtatic.com/packages/php53/

    He wants PHP 5.1 on CentOS 6, not PHP 5.3 on CentOS 5.x.

    @miTgiB said: ...php compiled from source is fine, the sky is not falling.

    Guess we differ on this. I don't think PHP 5.1 compiled from source is fine...

  • @sleddog : I think the repo will pick up the latest php for that OS version.

    OpenVZ | Los Angeles, California | 8 Cores CPU | 3 GB RAM | 50 GB Disk | 3 TB bandwidth/month | $30/Year | Here !
  • @SpeedBus said: @sleddog : I think the repo will pick up the latest php for that OS version.

    Which is not PHP 5.1. Which is what the OP wants.

  • SpeedBusSpeedBus Member
    edited December 2011

    @sleddog : Hmm.. I know.. but just wanted to suggest a newer version which would help.. anyway..

    EDIT : Thanks to the OP, this reminded me to update PHP installed on my VPS ;)

    OpenVZ | Los Angeles, California | 8 Cores CPU | 3 GB RAM | 50 GB Disk | 3 TB bandwidth/month | $30/Year | Here !
  • I prefer php 5.3 but Zend Optimizer does not support php 5.3 which is required on new server as some sites are using zend encoded scripts. I think I will go with OS realod. thanks everybody for help :)

  • I prefer php 5.3 but Zend Optimizer does not support php 5.3

    @glober, use zend guard

    Qenox Networks Inc. - KVM based VPS
  • @qenox, tried that did not worked on CentOs. I think I will better off with CentOS 5.7 for now.

  • @glober : CentOS 5.7 should be good, as a yum install php, installs php version 5.1.x

    Don't enable any external repos, keep the ones which come with CentOS itself ;)

    OpenVZ | Los Angeles, California | 8 Cores CPU | 3 GB RAM | 50 GB Disk | 3 TB bandwidth/month | $30/Year | Here !
  • @glober, what exactly didn't work? I'm pretty sure we have it running on CentOS 6.1 with php 5.3.

    Qenox Networks Inc. - KVM based VPS
  • @qenox I must admit that I did not take zend guard seriously before but I tried it now and its working fine. :)

    PHP 5.3.3 (cli) (built: Nov 3 2011 12:00:26) Copyright (c) 1997-2010 The PHP Group Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies with Zend Guard Loader v3.3, Copyright (c) 1998-2010, by Zend Technologies

  • InfinityInfinity Retired Staff
    edited December 2011

    You are meant to use Zend Guard Loader for php5.3, however I could never manage to get it working with the script I was using.

    我是一个巨魔 (;

  • @miTgiB said: All you need is to be 1 revision out for hell to surface, php compiled from source is fine, the sky is not falling.

    Actually for wordpress 3.2 and above, they now require php 5.2.4 and above:

    http://wordpress.org/about/requirements/

  • It's never a good idea to run an older version of PHP, especially that old... No matter what.

    Thanked by 1Infinity
Sign In or Register to comment.