Site will not load after switching to Cloud Fare

Site will not load after switching to Cloud Fare

gowtham101gowtham101 Member
edited August 2012 in General

So I switched to cloud fare and suddenly, my site does not load, it responds to ping, ssh, but the request always times out!!

P.S:- I am using BuyVM and this is on a sub domain

Use BuyVM, GEEK <3

Comments

  • Are you sure you're not pinging to cloudflare's servers?

    Catalyst Host - Pie Approved!
  • @HalfEatenPie Hmm what do you mean ?

    Use BuyVM, GEEK <3

  • Oh wait I misread what you wrote (lack of sleep does that to ya). So just to clarify @gowtham101, you can ping your server and SSH into your server using the cloudflare-protected Domain name correct? The only thing that its not working on is the Webpage?

    Catalyst Host - Pie Approved!
  • You can turn off cloudflare temporarily by enabling development mode or click on the orange cloud to turn it off

  • @HalfEatenPie correct ;)

    Use BuyVM, GEEK <3

  • Do what @bdtech said and try that. Test to see if its cloudflare's problem or your server's problem first.

    Catalyst Host - Pie Approved!
  • @HalfEatenPie My server was running fine before the switch, is lighttpd's virtual hosts not compatible with Cloud Fare ?

    Use BuyVM, GEEK <3

  • I'm not too sure but depending on your previous test I'd say look at this:

    https://www.cloudflare.com/wiki/Lighttpd

    I'm heading out, but yeah I'm sure other people can help you out with this.

    Catalyst Host - Pie Approved!
    1. Check your iptables using iptables --list to ensure that Cloudflare IPs are not being blocked.
    2. Do a nslookup on your Cloudflare-enabled domain, then ping/traceroute the resulting IPs from your server and see if you can reach them (this is not fully reliable due to anycasting).
    3. If all of the above is fine, contact Cloudflare support - they're very helpful, also for free users.

    Appreciate my posts/software/guides? Donate (PayPal/Flattr/Bitcoin): http://cryto.net/~joepie91/donate.html | irc.freenode.net #lowendbox

  • First try disabling CloudFlare as previously outlined. You running fail2ban or have a rule to limit # of connections from one IP?

    https://www.cloudflare.com/ips

    Whitelist CloudFlare Service IP Ranges

    iptables -A INPUT -p tcp --dport 80 -d 204.93.240.0/24 -j ACCEPT iptables -A INPUT -p tcp --dport 80 -d 204.93.177.0/24 -j ACCEPT iptables -A INPUT -p tcp --dport 80 -d 199.27.128.0/21 -j ACCEPT iptables -A INPUT -p tcp --dport 80 -d 173.245.48.0/20 -j ACCEPT iptables -A INPUT -p tcp --dport 80 -d 103.22.200.0/22 -j ACCEPT iptables -A INPUT -p tcp --dport 80 -d 141.101.64.0/18 -j ACCEPT iptables -A INPUT -p tcp --dport 80 -d 108.162.192.0/18 -j ACCEPT iptables -A INPUT -p tcp --dport 80 -d 190.93.240.0/20 -j ACCEPT

Sign In or Register to comment.