Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with OpenID
Advertise on LowEndTalk.com

In this Discussion

Issue.. Plox? Halp! -- Passwordless SSH.

Issue.. Plox? Halp! -- Passwordless SSH.

eastoncheastonch Member
edited July 2012 in General

Herro guys... got a stitch, I used ssh-keygen -t rsa to help me get password-less logins between server A and server B.

So.. I did that command on server B(prometeus); and moved the rsa.pub key over to server A(IPXCORE). I added the contents to authorized_keys and assumed that was all it needed.... Anyhow, it still prompts me for a password everytime... (There was no passphrase added).

<

pre> OpenSSH_5.5p1 Debian-6+squeeze2, OpenSSL 0.9.8o 01 Jun 2010 debug1: Reading configuration data /etc/ssh/ssh_config debug1: Connecting to my128pro.chriseaston.info [-] port-. debug1: Connection established. debug1: permanently_set_uid: 0/0 debug1: identity file /root/.ssh/id_rsa type -1 debug1: identity file /root/.ssh/id_rsa-cert type -1 debug1: identity file /root/.ssh/id_dsa type -1 debug1: identity file /root/.ssh/id_dsa-cert type -1 debug1: Remote protocol version 2.0, remote software version OpenSSH_5.5p1 Debian-6+squeeze2 debug1: match: OpenSSH_5.5p1 Debian-6+squeeze2 pat OpenSSH- debug1: Enabling compatibility mode for protocol 2.0 debug1: Local version string SSH-2.0-OpenSSH_5.5p1 Debian-6+squeeze2 debug1: SSH2_MSG_KEXINIT sent debug1: SSH2_MSG_KEXINIT received debug1: kex: server->client aes128-ctr hmac-md5 none debug1: kex: client->server aes128-ctr hmac-md5 none debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP debug1: SSH2_MSG_KEX_DH_GEX_INIT sent debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY debug1: Host '[my128pro.chriseaston.info]:-' is known and matches the RSA host key. debug1: Found key in /root/.ssh/known_hosts:2 debug1: ssh_rsa_verify: signature correct debug1: SSH2_MSG_NEWKEYS sent debug1: expecting SSH2_MSG_NEWKEYS debug1: SSH2_MSG_NEWKEYS received debug1: Roaming not allowed by server debug1: SSH2_MSG_SERVICE_REQUEST sent debug1: SSH2_MSG_SERVICE_ACCEPT received debug1: Authentications that can continue: publickey,password debug1: Next authentication method: publickey debug1: Trying private key: /root/.ssh/id_rsa debug1: Trying private key: /root/.ssh/id_dsa debug1: Next authentication method: password- that's my -v output anyhow; I tried changing the hostname of the B server from my128pro to my128pro.chriseaston.info and added the redirect from my namecheap domain.

I havent fucked with this anymore, I tried KeyChain, but that also flopped. Anything i've missed?

Comments

  • Did you enable public key auth on the server and restart SSH afterwards?

    President Of Operations/CEO/CFO/CTO/COO of my account
    image

  • On which server, and what's the correct usage, I used minstall's "optimal ssh" setup...

  • I added PubkeyAuthentication yes to both A and B, and service ssh restart both.

    Now I get;

     
    
    debug1: Authentications that can continue: publickey,password
    debug1: Next authentication method: publickey
    debug1: Trying private key: /root/.ssh/id_rsa
    debug1: Trying private key: /root/.ssh/id_dsa
    debug1: Next authentication method: password
    
  • gsrdgrdghdgsrdgrdghd Member
    edited July 2012

    You need to have this in your sshd_config (on the server):

    RSAAuthentication yes
    PubkeyAuthentication yes
    AuthorizedKeysFile      %h/.ssh/authorized_keys

    They will already be there but maybe commented out

    President Of Operations/CEO/CFO/CTO/COO of my account
    image

  • eastoncheastonch Member
    edited July 2012

    Nope, added it to both...

    
    HostKey /etc/ssh/ssh_host_rsa_key
    HostKey /etc/ssh/ssh_host_dsa_key
    Protocol 2
    Subsystem sftp /usr/lib/openssh/sftp-server -u 0007
    
    ChallengeResponseAuthentication no
    PermitRootLogin yes
    UsePAM yes
    UsePrivilegeSeparation yes
    PubkeyAuthentication yes
    RSAAuthentication yes
    AuthorizedKeysFile ~/.ssh/authorized_keys
    

    Is the same for both servers; except the other has Port xxx ...

    I also tried removing each other from "known hosts"; Still failed.

  • I used ssh-keygen -t rsa to help me get password-less logins between server A and server B

    have you done an ssh-add /path/to/privkey on the machine you connect from? ssh-add -l gives you the keys ssh-agent knows about

  • lawllawl Member

    if you try to login as root you might need to set PermitRootLogin without-password (assuming openssh)

  • NickMNickM Member

    How about the output from ssh -vv ?

    Lead Developer - HostGuard Control Panel

  • Stupid question maybe, but are you trying to SSH from server A to server B or the other way around?

    Appreciate my posts/software/guides? Donate (PayPal/Flattr/Bitcoin): http://cryto.net/~joepie91/donate.html | irc.freenode.net #lowendbox

Sign In or Register to comment.